Windows Message Queue 优先队列

题目

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

Sample Input

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

Sample Output

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

题意

给你最多60000条指令,"GET"表示获取指令,如果队列为空,输出"EMPTY QUEUE!"。"PUT"表示放置指令,每条指令都有一个参数和一个表示优先级的数,且如果优先级数越大,优先级越小,如果优先级相同,则先出现的消息优先被处理。

分析

优先队列,注意优先级相同时,先出现的消息优先被处理,所以记录一下每条消息出现的时间,在结构体内重载一下'<'就可以了(写这个题就是为了记个模板)。

代码

#include<iostream>
#include<cstdio>
#include<string.h>
#include<queue>
using namespace std;
#define inf 0x3f3f3f
const int N=6e4+5;
struct node{
	char s[1005];
	int can,id,time;
	bool operator < (const node &a) const//重载'<' 
	{
		if(id==a.id)
			return time>a.time;
		return id>a.id;
	}
}num;
int main()
{
	priority_queue<node> q;
	char t[5];
	int cas=1;
	while(~scanf("%s",t))
	{
		if(t[0]=='G')
		{
			if(q.empty())
				printf("EMPTY QUEUE!\n");
			else
			{
				node tmp=q.top();
				q.pop();
				printf("%s %d\n",tmp.s,tmp.can);
			}
		}
		else if(t[0]=='P')
		{
			scanf("%s",num.s);
			scanf("%d%d",&num.can,&num.id);
			num.time=cas++;
			q.push(num);
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值