Examining the Rooms(第一类Stirling数的运用)

Examining the Rooms

题目大意就是:有一家宾馆发生了谋杀案,探长要去检查宾馆里的所有房间,但是每个房间的钥匙都锁在了一间客里(有可能是相同的),探长只有先撞开其中一间客房,调查完后找到其中的钥匙,并用这把钥匙去打开下一间客房,这就意味着钥匙会把其中几个房间连成一个环,撞开这个环中的一个房间就能打开这个环中所有的房间。但还有一个条件,探长不能去撞1号房间的门,因为那里住的是VIP客户,所以只有找到钥匙才能进1号房间。最后要求探长最多只能撞开k个房间的门,问他可以打开所有房间的几率是多少。
如果从环这个角度来看就会简单不少,钥匙会把其中一些房间连成环,最多撞门k次,也就是说环的个数不超过k个,并且1号房不能独成一个环。
块状注释部分只是用来输出n小于25的所有第一类Stirling数,结果发现只有当n<=20,数据会在__int64的范围内,也正好题目给出的n小于等于20,不然肯定会要求结果取余。

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 10   Accepted Submission(s) : 7
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

A murder happened in the hotel. As the best detective in the town, you should examine all the N rooms of the hotel immediately. However, all the doors of the rooms are locked, and the keys are just locked in the rooms, what a trap! You know that there is exactly one key in each room, and all the possible distributions are of equal possibility. For example, if N = 3, there are 6 possible distributions, the possibility of each is 1/6. For convenience, we number the rooms from 1 to N, and the key for Room 1 is numbered Key 1, the key for Room 2 is Key 2, etc.
To examine all the rooms, you have to destroy some doors by force. But you don’t want to destroy too many, so you take the following strategy: At first, you have no keys in hand, so you randomly destroy a locked door, get into the room, examine it and fetch the key in it. Then maybe you can open another room with the new key, examine it and get the second key. Repeat this until you can’t open any new rooms. If there are still rooms un-examined, you have to randomly pick another unopened door to destroy by force, then repeat the procedure above, until all the rooms are examined.
Now you are only allowed to destroy at most K doors by force. What’s more, there lives a Very Important Person in Room 1. You are not allowed to destroy the doors of Room 1, that is, the only way to examine Room 1 is opening it with the corresponding key. You want to know what is the possibility of that you can examine all the rooms finally.

Input

The first line of the input contains an integer T (T ≤ 200), indicating the number of test cases. Then T cases follow. Each case contains a line with two numbers N and K. (1 < N ≤ 20, 1 ≤ K < N)

Output

Output one line for each case, indicating the corresponding possibility. Four digits after decimal point are preserved by rounding.

Sample Input

3
3 1
3 2
4 2

Sample Output

0.3333
0.6667
0.6250

Hint

Sample Explanation

When N = 3, there are 6 possible distributions of keys:

  Room 1  Room 2  Room 3  Destroy Times
#1  Key 1  Key 2  Key 3  Impossible
#2  Key 1  Key 3  Key 2  Impossible
#3  Key 2  Key 1  Key 3  Two
#4  Key 3  Key 2  Key 1  Two
#5  Key 2  Key 3  Key 1  One
#6  Key 3  Key 1  Key 2  One

In the first two distributions, because Key 1 is locked in Room 1 itself and you can’t destroy Room 1, it is impossible to open Room 1. 
In the third and forth distributions, you have to destroy Room 2 and 3 both. In the last two distributions, you only need to destroy one of Room 2 or Room

#include <iostream>
#include <cstdio>
using namespace std;
__int64 s[25][25];
void table()
{
int i,j;
for(i=0;i<25;i++)
{
s[i][0]=0;
s[i][i]=1;
for(j=1;j<i;j++)
{
s[i][j]=((i-1)*s[i-1][j]+s[i-1][j-1]);
}
}
return ;
}
int main(int argc, char *argv[])
{
int t,n,k,i,j;
__int64 a,b;
table();
/*for(i=0;i<25;i++)
{
for(j=1;j<=i;j++) cout<<i<<" "<<j<<" "<<s[i][j]<<endl;
}*/
cin>>t;
while(t--)
{
cin>>n>>k;
a=b=0;
for(i=1;i<=n;i++) b+=s[n][i];\\b记下所有可能的环排列
for(i=1;i<=k-1;i++) a+=s[n-1][i];\\a记下所有探长不可能完成任务的环排列,
包括1号房独成一个环,

for(i=k+1;i<=n;i++) a+=s[n][i];\\以及环数超过k个的情况
printf("%.4f\n",1-1.0*a/b);
}
return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值