畅通工程续
Time Limit : 3000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 44 Accepted Submission(s) : 23
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。
现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
Input
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
Sample Input
3 3 0 1 1 0 2 3 1 2 1 0 2 3 1 0 1 1 1 2
Sample Output
2 -1
#include <iostream>
#include <queue>
#include <cstdio>
#define INF 1000000
#define MAXN 205
using namespace std;
struct ArcNode
{
int to;
int weight;
ArcNode *next;
};
queue<int> Q;
int n,m;
ArcNode *List[MAXN];
int inq[MAXN];
int dist[MAXN],path[MAXN];
void SPFA(int src)
{
int i,u;
ArcNode *temp;
for(i=0;i<n;i++)
{
dist[i]=INF;path[i]=src;inq[i]=0;
}
dist[src]=0;path[src]=src;inq[src]++;
Q.push(src);
while(!Q.empty())
{
u=Q.front();Q.pop();inq[u]--;
temp=List[u];
while(temp!=NULL)
{
int v=temp->to;
if(dist[v]>dist[u]+temp->weight)
{
dist[v]=dist[u]+temp->weight;path[v]=u;
if(!inq[v]){Q.push(v);inq[v]++;}
}
temp=temp->next;
}
}
}
int main(int argc, char *argv[])
{
int i,j;
int start,end;
int u,v,w;
while(cin>>n>>m)
{
memset(List,0,sizeof(List));
ArcNode *temp;
for(i=0;i<m;i++)
{
scanf("%d%d%d",&u,&v,&w);
temp=new ArcNode;
temp->to=v;temp->weight=w;temp->next=NULL;
if(List[u]==NULL) List[u]=temp;
else {temp->next=List[u];List[u]=temp;}
temp=new ArcNode; //由于SPFA只是计算有向路径,而这里给的是无向的
temp->to=u;temp->weight=w;temp->next=NULL; //所以要倒过来再插入一个反向链表
if(List[v]==NULL) List[v]=temp;
else {temp->next=List[v];List[v]=temp;}
}
cin>>start>>end;
SPFA(start);
for(j=0;j<n;j++)
{
temp=List[j];
while(temp!=NULL)
{
List[j]=temp->next;delete temp;temp=List[j];
}
}
if(dist[end]!=INF) cout<<dist[end]<<endl;
else cout<<"-1"<<endl;
}
return 0;
}