A strange lift
Time Limit : 2000/1000ms(Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) :133 Accepted Submission(s) : 25
ProblemDescription
Thereis a strange lift.The lift can stop can at every floor as you want, and thereis a number Ki(0 <= Ki <= N) on every floor.The lift have justtwo buttons: up and down.When you at floor i,if you press the button"UP" , you will go up Ki floor,i.e,you will go to the i+Ki thfloor,as the same, if you press the button "DOWN" , you willgo down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the liftcan't go up high than N,and can't go down lower than 1. For example, there is abuliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining fromthe 1 st floor,you can press the button "UP", and you'll goup to the 4 th floor,and if you press the button "DOWN", thelift can't do it, because it can't go down to the -2 th floor,as you know ,the-2 th floor isn't exist.<br>Here comes the problem: when you is on floorA,and you want to go to floor B,how many times at least he havt to press thebutton "UP" or "DOWN"?<br>
Input
Theinput consists of several test cases.,Each test case contains twolines.<br>The first line contains three integers N ,A,B( 1 <= N,A,B<= 200) which describe above,The second line consist N integersk1,k2,....kn.<br>A single 0 indicate the end of the input.
Output
Foreach case of the input output a interger, the least times you have to press thebutton when you on floor A,and you want to go to floor B.If you can't reachfloor B,printf "-1".
SampleInput
5 15<br>3 3 1 2 5<br>0
SampleOutput
3
题意:
一个特别的电梯,按up可升上k[i]层,到大i+k[i]层,down则到达i-k[i]层,最高不能超过n
,最低不能小于1,给你一个起点和终点,问最少可以按几次到达目的地。
在一个N层高的楼有一个奇怪的电梯,在每一层只能上升或下降一个特定的层数,中间不会停止,在
给定的条件下,问能不能到达指定楼层,可以到达的话返回转操作次数,不可以的话返回-1.
解题思路:
这题是最简单最纯粹的bfs广搜,只要作一下标记去过的地方,不能再去,就OK啦!
#include <iostream>
#include <stdio.h>
#include <memory.h>
#include <queue>
using namespace std;
int N, A, B;
int a[205];
bool map[205], flag;
struct node
{
int x, step;
}n1, n2, m;
int main()
{
int i;
while(scanf("%d", &N), N)
{
if(N == 0) break;
scanf("%d %d", &A,&B);
for(i = 1; i <= N; i++)
{
scanf("%d", &a[i]);
map[i] = false;
}
flag = false;
n1.x = A; n1.step = 0;
queue<node> Q;
Q.push(n1);
map[n1.x] = true;
while(!Q.empty())
{
m = Q.front();
Q.pop();
if(m.x == B) //到达目标
{
flag = true;
break;
}
n1.x = m.x - a[m.x];
n2.x = m.x + a[m.x];
if(n1.x>0 && n1.x<=B&& !map[n1.x]) //下去的
{
n1.step = m.step + 1;
map[n1.x] = true; //标记
Q.push(n1);
}
if(n2.x>0 && n2.x<=B&& !map[n2.x]) //上去的
{
n2.step = m.step + 1;
map[n2.x] = true; //标记
Q.push(n2);
}
}
if(flag) printf("%d\n",m.step);
else printf("-1\n");
}
return 0;
}