51nod n^n的末位数字(快速幂||找循环节)

给出一个整数N,输出N^N(N的N次方)的十进制表示的末位数字。

Input 一个数N(1 <= N <= 10^9) Output 输出N^N的末位数字 Sample Input
13
Sample Output
3
方法很多:快速幂可以,找循环节也可以。快速幂:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define LL long long
int pow(LL a,LL b)
{
    int ans=1;
    while(b)
    {
        if(b&1) ans=(ans*a)%10;
        a=(a*a)%10;//a*a会爆int,所以用long long,不用long long也可以,a进来的时候取余10就行
        b>>=1;
    }
    return ans;
}
int main()
{
    LL n;
    scanf("%lld",&n);
    printf("%d\n",pow(n,n));
}
找寻环节:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
int ans[1000000];
int main()
{
    long long a;
    scanf("%lld",&a);
    int b=a%10;
    ans[0]=a%10;
//    if(b==0) printf("0\n");//注释的这几行可有可无
//    else
//    {
        int i;
        for(i=1;i<a;i++)
        {
            ans[i]=(ans[i-1]*b)%10;
            if(ans[i]==b)
                break;
        }
//        if(i==a) printf("%d\n",ans[i-1]);
//        else if(i==1) printf("%d\n",b);
//        else
//        {
            if(a%i==0) printf("%d\n",ans[i-1]);
            else printf("%d\n",ans[a%(i)-1]);
//        }
//    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值