poj 2823

 题目描述:

 

    

Sliding Window
Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 16559 Accepted: 4745
Case Time Limit: 5000MS

Description

An array of size n ≤ 10 6 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

      这道题主流的解法有两个,一个是线段树,另一个是单调队列。这里我是用单调队列过的。单调队列的相关知识可以去一下链接:
这里我就不在多说单调队列的相关知识了,说说自己的感悟,就是针对一种特定性质的单调队列可以由两条队列“复合”而成,一个管理要求的最值,另一个用于维护下标范围(可以联想一下我们平时解dp题时是怎么做的,是不是状态转移时都有一个范围?^_^)。感觉上单调队列很适合解决线性dp,比如区间最值、区间和最值等。
以下是AC代码,5000+ms的,自己手写scanf和printf可以提速到800+ms
  1. #include "stdio.h"
    #include "string.h"
    const int M=1000005;
    int arr[M];
    int Minq[M],Maxq[M];
    int Q[M],Inq[M];
    int n,k;
  2. void Min()
    {
     int head=1,tail=0;
     int i;
     for(i=1;i<=n;i++)
     {
      while(head<=tail && Q[tail]>arr[i])
       tail--;
      tail++;
      Q[tail]=arr[i];
      Inq[tail]=i;
      if(i>=k)
      {
       while(Inq[head]<=i-k) head++;
       Minq[i-k]=Q[head];
      }
     }
    }
  3. void Max()
    {
     int head=1,tail=0;
     int i;
     for(i=1;i<=n;i++)
     {
      while(head<=tail && Q[tail]<arr[i])
       tail--;
      tail++;
      Q[tail]=arr[i];
      Inq[tail]=i;
      if(i>=k)
      {
       while(Inq[head]<=i-k) head++;
       Maxq[i-k]=Q[head];
      }
     }
    }
  4. int main()
    {
     freopen("in.txt","r",stdin);
     while(scanf("%d%d",&n,&k)==2)
     {
      if(k>n) k=n;
      int i;
      for(i=1;i<=n;i++)
       scanf("%d",&arr[i]);
      Min();
      Max();
      for(i=0; i<n-k+1; i++)  
                printf("%d%c", Minq[i], (i < n - k) ? ' ' : '/n');   
            for(i=0; i<n-k+1; i++)  
                printf("%d%c", Maxq[i], (i < n - k) ? ' ' : '/n');   
     }
     return 0;
    }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值