【PAT甲级 - C++题解】1153 Decode Registration Card of PAT

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1153 Decode Registration Card of PAT (pintia.cn)
🔑中文翻译:解码PAT准考证
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1153 Decode Registration Card of PAT

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee’s number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤104) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner’s score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt’s, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA
思路

PAT 准考证号由 4 部分组成:

  • 1 位是级别,即 T 代表顶级;A 代表甲级;B 代表乙级;
  • 2∼4 位是考场编号,范围从 101999
  • 5∼10 位是考试日期,格式为年、月、日顺次各占 2 位;
  • 最后 11∼13 位是考生编号,范围从 000999

具体思路如下:

  1. 输入所有的准考证信息,用一个结构体数组存储,方便后续排序使用。
  2. 每个样例都先输出 Case T: t c
    1. 如果 type==1 ,需要我们按照分数降序输出,如果分数相等则按照 id 的字典序从小到大输出。
    2. 如果 type==2 ,需要输出与考场编号 c 相同的所有人的成绩总和。
    3. 如果 type==3 ,需要输出与考试日期 c 相同的考场编号以及对应人数。
  3. 注意,如果上面需要输出的信息不存在,则输出 NA 即可。
代码
#include<bits/stdc++.h>
using namespace std;

const int N = 10010;
int n, m;
struct Person
{
    string id;
    int grade;
    bool operator <(const Person& p)const
    {
        if (grade != p.grade)  return grade > p.grade;   //按照分数降序
        return id < p.id; //按照id字典序升序
    }
}p[N];

int main()
{
    cin >> n >> m;

    //输入所有准考证信息
    for (int i = 0; i < n; i++)    cin >> p[i].id >> p[i].grade;

    for (int i = 1; i <= m; i++)
    {
        string t, c;
        cin >> t >> c;
        printf("Case %d: %s %s\n", i, t.c_str(), c.c_str());

        if (t == "1")
        {
            vector<Person> persons;
            for (int i = 0; i < n; i++)    //将符合等级的加入数组中
                if (p[i].id[0] == c[0])
                    persons.push_back(p[i]);

            sort(persons.begin(), persons.end());    //排序

            if (persons.empty()) puts("NA");
            else
                for (auto x : persons)
                    printf("%s %d\n", x.id.c_str(), x.grade);
        }
        else if (t == "2")
        {
            int sum = 0, cnt = 0;
            for (int i = 0; i < n; i++)
                if (p[i].id.substr(1, 3) == c)
                    sum += p[i].grade, cnt++;

            if (!cnt)    puts("NA");
            else    printf("%d %d\n", cnt, sum);
        }
        else
        {
            //先用哈希表对考场编号进行分类
            unordered_map<string, int> hash;
            for (int i = 0; i < n; i++)
                if (p[i].id.substr(4, 6) == c)
                    hash[p[i].id.substr(1, 3)]++;

            //再用容器进行排序操作
            vector<pair<int, string>> rooms;
            for (auto x : hash)    //加负号相当于进行降序操作
                rooms.push_back({ -x.second,x.first });

            sort(rooms.begin(), rooms.end());

            if (rooms.empty())   puts("NA");
            else
                for (auto x : rooms)
                    printf("%s %d\n", x.second.c_str(), -x.first);
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值