【PAT甲级 - C++题解】1019 General Palindromic Number

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1100 Mars Numbers (pintia.cn)
🔑中文翻译:普通回文数
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1019 General Palindromic Number

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a**i as ∑i=0k(aib**i). Here, as usual, 0≤a**i<b for all i and a**k is non-zero. Then N is palindromic if and only if a**i=a**ki for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤109 is the decimal number and 2≤b≤109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form “a**k a**k−1 … a0”. Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1
题意

这道题给定一个十进制数 n 和进制 b ,需要我们将 n 转换成 b 进制,然后判断 b 进制下该数是否是回文数,最后还要输出转换成 b 进制的数。

思路
  1. 先用一个 vector 容器存转换成 b 进制的每一位数。
  2. 判断 b 进制下的数是否为回文数。
  3. 输出转换成 b 进制的数,注意这里需要从后往前输出,因为存数的时候下标为 0 的位置存的是最低位。
代码
#include<bits/stdc++.h>
using namespace std;

//判断是否是回文数
bool check(vector<int> x)
{
    for (int i = 0, j = x.size() - 1; i < j; i++, j--)
        if (x[i] != x[j])
            return false;
    return true;
}

int main()
{
    int n, b;
    cin >> n >> b;

    //将十进制数转船成b进制
    vector<int> ans;
    if (n == 0)    ans.push_back(0);
    while (n)
    {
        ans.push_back(n % b);
        n /= b;
    }

    //判断b进制下该数是否是回文数
    if (check(ans))  puts("Yes");
    else puts("No");

    //输出b进制下的数
    cout << ans[ans.size() - 1];
    for (int i = ans.size() - 2; i >= 0; i--)
        cout << " " << ans[i];

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值