【PAT甲级 - C++题解】1106 Lowest Price in Supply Chain

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1106 Lowest Price in Supply Chain (pintia.cn)
🔑中文翻译:供应链最低价格
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1106 Lowest Price in Supply Chain

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K i K_i Ki ID[1] ID[2] … ID[ K i K_i Ki]

where in the i-th line, K i K_i Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. K j K_j Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K j K_j Kj . All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

Sample Output:

1.8362 2
题意

供应链是由零售商,经销商和供应商构成的销售网络,每个人都参与将产品从供应商转移到客户的过程。

整个销售网络可以看作一个树形结构,从根部的供应商往下,每个人从上一级供应商中买入商品后,假定买入价格为 P ,则会以高出买入价 r% 的价格向下出售。

只有零售商(即叶节点)可以直接将产品销售给顾客。

现在,给定整个销售网络,输出零售商可达到的最低销售价格,保留四位小数,以及可达到最低销售价格的零售商的数量。

第一行包含三个数,N 表示供应链总成员数(所有成员编号从 0N−1 ,根部供应商编号为 0 ),P 表示根部供应商的每件产品的售卖价格,r ,溢价百分比。

接下来 N 行,每行包含一个成员的信息,格式如下:

Ki ID[1] ID[2] … ID[Ki]

其中第 i 行,Ki 表示从供应商 i 直接进货的成员数,接下来 Ki 个整数是每个进货成员的编号。

如果某一行的 Kj0 ,则表示这是零售商。

思路
  1. 我们可以用一个数组 p 来存储每个结点的父结点,并且再用一个数组 is_leaf 来判断每个结点是否是叶子结点。另外,当 k0 时,代表该结点是根供应商。
  2. 通过树形 DP 来计算树的深度,用一个 f 数组来存储每次计算的值,这样就可以排除重复计算的步骤。
  3. 计算总销售额时只用判断每次遍历的结点是否为叶子结点即可,然后通过公式 P * pow(1 + R / 100, dfs(i)) 计算该叶子结点即零售商的销售额。其中,P 表示产品的单位价格,pow(1 + R / 100, dfs(i)) 则是计算 1 + R/100dfs(i) 次方即每多一层关系次方数就加 1 。每次计算完之后,再去判断当前深度是否是最小值(因为价格是固定的,所以深度越小的零售商的销售额越小),如果是最小值则更新答案,如果等于最小值则最小销售额的销售商数量加 1
  4. 输出最终结果,注意销售额最小值保留四个小数点。
代码
#include<bits/stdc++.h>
using namespace std;

const int N = 100010;
int n;
double P, R;
int p[N], f[N];
bool is_leaf[N];

//树形DP,记忆化搜索
int dfs(int u)
{
    //剪枝,如果f[u]已经被计算过,直接返回即可
    if (f[u] != -1)    return f[u];
    //如果该结点没有父结点,直接返回0,同时更新f[u]
    if (p[u] == -1)    return f[u] = 0;
    return f[u] = dfs(p[u]) + 1;
}

int main()
{
    cin >> n >> P >> R;

    //输入结点信息
    memset(p, -1, sizeof p);
    for (int i = 0; i < n; i++)
    {
        int k;
        cin >> k;
        for (int j = 0; j < k; j++)
        {
            int son;
            cin >> son;
            p[son] = i;   //记录父结点是谁
        }
        if (!k)  is_leaf[i] = true;
    }

    memset(f, -1, sizeof f);

    //找到从根结点到叶子结点最短的深度
    int res = n, cnt = 0;
    for (int i = 0; i < n; i++)
        if (is_leaf[i])
        {
            if (dfs(i) < res)  res = dfs(i), cnt = 1;
            else if (dfs(i) == res)    cnt++;
        }

    printf("%.4lf %d\n", P * pow(1 + R / 100, res), cnt);

    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值