【PAT甲级 - C++题解】1151 LCA in a Binary Tree

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1151 LCA in a Binary Tree (pintia.cn)
🔑中文翻译:二叉树中的最低公共祖先
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1151 LCA in a Binary Tree

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.
题意

树中两个结点 UV 的最低公共祖先(LCA)是指同时具有 UV 作为后代的最深结点。

第一行输入给定 M M M N N N ,表示有 N N N 个结点和 M M M 行询问。

第二行给定该二叉树的中序遍历结果,第三行给定该二叉树前序遍历的结果。

接下来的 M M M 行表示要查询的两个结点,需要我们查找这两个结点是否在树中且有公共结点,如果有则输出对应结果。

思路

这道题的思路和 1143 那题思路一模一样,只是对于输入的处理稍微不同。这里处理的是二叉树而不是二叉搜索树,所以中序数组和后序数组是给定的,但是同样要先对数据进行离散化后再构建二叉树。

代码部分除了对于输入的处理不同外,其它部分和 1143 那题代码完全相同,那道题我进行了超详细的讲解,这里就不重复讲解啦,大家可以移步到那题去看看是如何实现的~

代码
#include<bits/stdc++.h>
using namespace std;

const int N = 10010;
int m, n;
int seq[N], pre[N];
int p[N], depth[N];
unordered_map<int, int> pos;

//构建二叉树
int build(int il, int ir, int pl, int pr, int d)
{
    int root = pre[pl];   //获得根结点
    int k = root;     //由于数据经历过离散化,所以root等于左子树的结点数

    depth[root] = d;  //记录该结点所在深度

    if (il < k)    p[build(il, k - 1, pl + 1, pl + 1 + k - il - 1, d + 1)] = root; //右子树
    if (ir > k)    p[build(k + 1, ir, pl + 1 + k - il - 1 + 1, pr, d + 1)] = root; //左子树

    return root;
}

int main()
{
    cin >> m >> n;

    //输入中序数组,并对数据进行离散化操作
    for (int i = 0; i < n; i++)
    {
        cin >> seq[i];
        pos[seq[i]] = i;  //对每个值进行离散化
    }

    //输入前序数组,并将前序数组中的值全部替换成离散后的值
    for (int i = 0; i < n; i++)
    {
        cin >> pre[i];
        pre[i] = pos[pre[i]];
    }

    build(0, n - 1, 0, n - 1, 0);   //构建二叉树

    //查找最低公共祖先
    while (m--)
    {
        int a, b;
        cin >> a >> b;

        if (pos.count(a) && pos.count(b))    //如果两个结点都在树中
        {
            a = pos[a], b = pos[b];  //先转换成离散化后的数值
            int x = a, y = b;    //备份要查找的两个结点

            while (a != b) //找到两个结点的公共结点为止
                if (depth[a] < depth[b])   b = p[b];
                else    a = p[a];

            //打印对应结果
            if (a != x && b != y)  printf("LCA of %d and %d is %d.\n", seq[x], seq[y], seq[a]);
            else if (a == x)   printf("%d is an ancestor of %d.\n", seq[x], seq[y]);
            else    printf("%d is an ancestor of %d.\n", seq[y], seq[x]);
        }
        else if (!pos.count(a) && !pos.count(b))  //如果两个结点都不在树中
            printf("ERROR: %d and %d are not found.\n", a, b);
        else if (!pos.count(a))  //如果第一个结点不在树中
            printf("ERROR: %d is not found.\n", a);
        else  //如果第二个结点不在树中
            printf("ERROR: %d is not found.\n", b);

    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值