【PAT甲级 - C++题解】1068 Find More Coins

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1068 Find More Coins (pintia.cn)
🔑中文翻译:找更多硬币
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1068 Find More Coins

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 104 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤104, the total number of coins) and M (≤102, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1≤V2≤⋯≤Vk such that V1+V2+⋯+Vk=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output “No Solution” instead.

Note: sequence {A[1], A[2], …} is said to be “smaller” than sequence {B[1], B[2], …} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution
题意

给定需要支付的金额以及所有硬币的面额,判断是否能用这些硬币刚好凑齐支付的金额。

思路

状态表示: f [ i ] [ j ] f[i][j] f[i][j] 表示只考虑前 i 个物品,总体积为 j 的选法是否存在。

状态计算:

如果不选当前物品: f [ i ] [ j ] = f [ i − 1 ] [ j ] f[i][j] = f[i - 1][j] f[i][j]=f[i1][j]

如果选当前物品: f [ i ] [ j ] ∣ = f [ i − 1 ] [ j − a [ i ] ] f[i][j] |= f[i - 1][j - a[i]] f[i][j]=f[i1][ja[i]]

这道题就是一个 01 背包问题,在计算完答案之后如果存在答案,则需要输出对应序列,就得从后往前判断每一个物品是否存在于答案序列中,如果存在就输出该值即可。

代码
#include<bits/stdc++.h>
using namespace std;

const int N = 10010, M = 110;
int a[N], f[N][M];
int n, m;

int main()
{
    cin >> n >> m;
    for (int i = 1; i <= n; i++)   cin >> a[i];

    //从大到小排序硬币面额
    sort(a + 1, a + n + 1, greater<int>());

    //动态规划计算是否存在答案
    f[0][0] = true;
    for (int i = 1; i <= n; i++)
        for (int j = 0; j <= m; j++)
        {
            f[i][j] = f[i - 1][j];
            if (j >= a[i]) f[i][j] |= f[i - 1][j - a[i]];
        }

    //判断是否存在答案,如果存在则输出答案序列 
    if (!f[n][m])    puts("No Solution");
    else
    {
        bool is_first = true;
        while (n)
        {
            if (m >= a[n] && f[n - 1][m - a[n]])
            {
                if (is_first)    is_first = false;
                else cout << " ";
                cout << a[n];
                m -= a[n];
            }
            n--;
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值