【PAT甲级 - C++题解】1137 Final Grading

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1137 Final Grading (pintia.cn)
🔑中文翻译:期终成绩
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1137 Final Grading

For a student taking the online course “Data Structures” on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G=(Gmidterm×40%+Gfinal×60%) if Gmidterm>Gfinal, or Gfinal will be taken as the final grade G. Here Gmidterm* and Gfinal are the student’s scores of the mid-term and the final exams, respectively.

The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

Then three blocks follow. The first block contains P online programming scores Gp’s; the second one contains M mid-term scores Gmidterm’s; and the last one contains N final exam scores Gfnal’s. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

Output Specification:

For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

StudentID Gp Gmidterm Gfinal G

If some score does not exist, output “−1” instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID’s. It is guaranteed that the StudentID’s are all distinct, and there is at least one qullified student.

Sample Input:

6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81

Sample Output:

missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84
题意

题目第一行给定做了编程作业人数、期中考试参加人数和期末考试参加人数。

接下来输入分三块,第一块输入做了编程作业的成绩单,第二块则是期中考试成绩单,第三块是期末考试成绩单。

我们需要从中找出满足合格证书要求的名单,而合格证书的要求是编程作业成绩不能少于 200 分,总评成绩不能少于 60 分。而总评的计算则需要根据期中成绩和期末成绩,如果期末成绩大于等于期中成绩,则总评就等于期末成绩;反之,总评等于期中成绩的 40% 加上期末成绩的 60%

输出则先按照总评成绩递减排序,如果总评相等则按照学号递增排序。

思路

具体思路如下:

  1. 用一个哈希表来存储所有学生信息,然后分别将三块信息存储在哈希表中。
  2. 根据要求,计算每个学生的总评成绩,并将满足合格证书的学生挑选出来放入答案数组 stu
  3. 按照题目要求进行排序,最后输出最终结果。
代码
#include<bits/stdc++.h>
using namespace std;

struct Student
{
    int p, m, f, g;
    string no;

    Student() :p(-1), m(-1), f(-1), g(0) {}

    //计算总评
    void calc()
    {
        if (f >= m)    g = f;    //期末成绩大于等于期中,期末就算总评
        else    g = round(0.4 * m + 0.6 * f);    //如果期中更小,则按公式计算
    }

    //重载比较运算
    bool operator <(const Student& s) const
    {
        //先按总评递减排序,再按名字递增排序
        if (g != s.g)  return g > s.g;
        return no < s.no;
    }
};

int main()
{
    int p, m, n;
    cin >> p >> m >> n;

    unordered_map<string, Student> hs;
    string id;
    int x;

    //输入第一块成绩
    for (int i = 0; i < p; i++)
    {
        cin >> id >> x;
        hs[id].no = id, hs[id].p = x;
    }

    //输入第二块成绩
    for (int i = 0; i < m; i++)
    {
        cin >> id >> x;
        hs[id].no = id, hs[id].m = x;
    }

    //输入第三块成绩
    for (int i = 0; i < n; i++)
    {
        cin >> id >> x;
        hs[id].no = id, hs[id].f = x;
    }

    //将满足合格证书要求的学生挑出来
    vector<Student> stu;
    for (auto& it : hs)
    {
        auto s = it.second;
        s.calc();   //计算总评
        //编程分数不少于200,总评不少于60
        if (s.p >= 200 && s.g >= 60)
            stu.push_back(s);
    }

    //按要求排序
    sort(stu.begin(), stu.end());

    //输出名单
    for (auto& s : stu)
        cout << s.no << " " << s.p << " " << s.m << " " << s.f << " " << s.g << endl;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值