【PAT甲级 - C++题解】1041 Be Unique

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1041 Be Unique (pintia.cn)
🔑中文翻译:独一无二
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1041 Be Unique

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None
题意

找出第一个只出现一次的数字。

思路

具体思路如下:

  1. 先将所有元素放入数组 a 中,并用哈希表 c 来记录每个元素出现的次数。
  2. 从头往后遍历 a 中元素,输出第一个在 c 中查找数值为 1 的元素,如果不存在则输出 None
代码
#include<bits/stdc++.h>
using namespace std;

const int N = 100010;
int a[N], c[N];
int n;

int main()
{
    cin >> n;

    //记录每个数出现的次数
    for (int i = 0; i < n; i++)
    {
        cin >> a[i];
        c[a[i]]++;
    }

    //找到最左边只出现一次的数字
    for (int i = 0; i < n; i++)
        if (c[a[i]] == 1)
        {
            cout << a[i] << endl;
            return 0;
        }
    puts("None");

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值