【PAT甲级 - C++题解】1037 Magic Coupon

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1037 Magic Coupon (pintia.cn)
🔑中文翻译:魔术卷
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1037 Magic Coupon

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with *N* being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1≤NC,NP≤105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43
题意

将题意简化后,实际上是给定了两个数组 ab ,需要我们计算 a 中元素与 b 中元素乘积可以得到的最大值,例如给定两个数组 {1,2,4,-1}{7,6,-2,-3} ,我们发现 4*7+2*6+-1*-3 可以得到最大值 43 ,其中 1-2 就不用配对了,因为得到的是负数可以省去。

思路

这道题用到了排队不等式思想,即给定两个数组,将这两个数组进行排序,得到如下:

a1 a2 a3 ... anb1 b2 b3 ... bn

那么将两个数组中最大的元素分别相乘并相加即 a1*b1+a2*b2+a3*b3+...an*bn ,得到的结果在所有相乘后并相加的结果中是最大的

在本题中,我们需要排除那些赋负权的相乘情况,例如题目例子中 1-2 的情况需要舍去,所以我们只需将两数组中的元素分成两个部分,一个是正数部分,一个是负数部分

然后对正数部分的值进行上述操作,如果两数组正数部分长度不同,则舍弃长度较长那个数组中多出来的正数小的值,例如下面两个数组的正数部分为:

1 3 5 72 4 6

由于第一个数组长度较长,所以需要舍弃最小正数 1 ,不然这个 1 就会和第二个数组中的负数进行配对(题目规定两数组长度相同,即如果正数少则相应负数就会更多)。

而负数也同理,需要舍弃长度较长那个数组中多出来的绝对值小的值。

所以具体思路如下:

  1. 先输入两个数组,并分别对两个数组进行排序。
  2. 将两数组中绝对值最大的负数元素相乘并相加,同样再对最大的正数相乘并相加。
  3. 输出最终结果。
代码
#include<bits/stdc++.h>
using namespace std;

const int N = 100010;
int a[N], b[N];
int n, m;

int main()
{
    //输入两个数组
    cin >> n;
    for (int i = 0; i < n; i++)    cin >> a[i];
    cin >> m;
    for (int i = 0; i < m; i++)    cin >> b[i];

    //对两个数组进行排序
    sort(a, a + n);
    sort(b, b + m);

    //计算最大优惠
    int res = 0;
    //先计算负数部分
    for (int i = 0, j = 0; i < n && j < m && a[i] < 0 && b[j] < 0; i++, j++)
        res += a[i] * b[j];
    //再计算正数部分
    for (int i = n - 1, j = m - 1; i >= 0 && j >= 0 && a[i] > 0 && b[j] > 0; i--, j--)
        res += a[i] * b[j];

    //输出结果
    cout << res << endl;

    return 0;
}
  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值