【PAT甲级 - C++题解】1070 Mooncake

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1070 Mooncake (pintia.cn)
🔑中文翻译:月饼
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1070 Mooncake

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region’s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45
题意

给定 n 种月饼的总重量和总价值,以及市场销售量 m ,要求计算可以获得的最大利润。

例如,给定三种月饼的总重量和总价值分别为:{180,150,100}{7.5,7.2,4.5} ,且市场销售额为 200 ,那么最大利润就是 7.2+4.5/2=9.45 ,题目要求保留 2 为小数。

思路

这题有一个坑,题目给的是每种月饼的总价值,而不是每种月饼的单价,所以需要我们计算每种月饼的性价比即单价,并按照月饼的性价比降序排序,选性价比最高的月饼卖。

具体思路如下:

  1. 输入每种月饼的总重量和总价值,按照性价比进行降序排序。
  2. 计算最大利润,把性价比最高的月饼卖出去,注意重量可以是小数。
  3. 输出最大利润,注意保留两位小数。
代码
#include<bits/stdc++.h>
using namespace std;

const int N = 1010;
int n;
double m;
struct Cake {
    double w, p;
    bool operator <(const Cake& t)const
    {
        //按照性价比进行降序排序
        return p / w > t.p / t.w;
    }
}c[N];

int main()
{
    cin >> n >> m;
    for (int i = 0; i < n; i++)    cin >> c[i].w;    //输入月饼重量
    for (int i = 0; i < n; i++)    cin >> c[i].p;    //输入月饼价值

    //按照月饼的性价比降序排序
    sort(c, c + n);

    //计算最大利润
    double res = 0;
    for (int i = 0; i < n && m>0; i++)
    {
        double r = min(m, c[i].w);
        m -= r;
        res += c[i].p / c[i].w * r;
    }

    //输出最大利润
    printf("%.2lf\n", res);

    return 0;
}
  • 8
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 7
    评论
评论 7
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值