【PAT甲级 - C++题解】1091 Acute Stroke

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1091 Acute Stroke (pintia.cn)
🔑中文翻译:急性中风
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1091 Acute Stroke

One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M×N matrix, and the maximum resolution is 1286 by 128); L (≤60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

Then L slices are given. Each slice is represented by an M×N matrix of 0’s and 1’s, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1’s to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are connected and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.
>[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-Qp4R7Kp7-1673139427377)(PAT 甲级辅导.assets/f85c00cc-62ce-41ff-8dd0-d1c288d87409.jpg)]

Figure 1

Output Specification:

For each case, output in a line the total volume of the stroke core.

Sample Input:

3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0

Sample Output:

26
题意

这题实际上就是一个求连通块数量的题目,给定一个 L×M×N 的三维矩阵和一个常量 T ,每个坐标只与其上下左右前后相连通,一个连通块的面积大于等于 T 就算危险中风区域,现在要求我们计算该三维矩阵中危险中风区域的总面积。

思路

由于 PAT 的内存限制,如果用 dfs 会爆栈,所以这题我们用 bfs 来做,具体思路如下:

  1. 输入地图,用一个三维数组 g 来存储,1 表示中风区域,0 表示正常区域。
  2. 遍历数组中的每一个坐标,如果该位置是中风区域,则计算与其相连通的区域面积。
    1. bfs 需要用到队列,初始化队列,同时在数组 g 中标记当前坐标为 0 即表示已遍历过。
    2. 每次遍历都从队列头部取出一个元素,然后判断其相邻的六个方向是否可达即同样也是中风区域,如果是则将该坐标加入到队列的尾部。
    3. 每加入一个坐标到队列,当前连通块面积 cnt 就加 1
  3. 如果当前遍历的连通块面积大于等于 T ,就加入到总面积 res 当中。
  4. 输出危险中风总面积 res
代码
#include<bits/stdc++.h>
using namespace std;

const int M = 1300, N = 130, L = 65;
int g[L][M][N];
int m, n, l, T;
struct Node {
    int x, y, z;
};

int d[][3] = {
    {1,0,0},
    {-1,0,0},
    {0,1,0},
    {0,-1,0},
    {0,0,1},
    {0,0,-1}
};

//宽度优先搜索求连通块面积
int bfs(int x, int y, int z)
{
    //初始化
    queue<Node> q;
    q.push({ x,y,z });
    g[x][y][z] = 0;

    //开始宽搜
    int cnt = 1;
    while (q.size())
    {
        auto t = q.front();
        q.pop();

        //遍历6个方向
        for (int i = 0; i < 6; i++)
        {
            int a = t.x + d[i][0], b = t.y + d[i][1], c = t.z + d[i][2];
            if (a >= 0 && a < l && b >= 0 && b < m && c >= 0 && c < n && g[a][b][c])
            {
                g[a][b][c] = 0;
                q.push({ a,b,c });
                cnt++;
            }
        }
    }

    return cnt;
}

int main()
{
    //输入地图
    scanf("%d%d%d%d", &m, &n, &l, &T);
    for (int i = 0; i < l; i++)
        for (int j = 0; j < m; j++)
            for (int k = 0; k < n; k++)
                scanf("%d", &g[i][j][k]);

    //计算危险中风区域面积
    int res = 0;
    for (int i = 0; i < l; i++)
        for (int j = 0; j < m; j++)
            for (int k = 0; k < n; k++)
                if (g[i][j][k])
                {
                    int cnt = bfs(i, j, k);
                    if (cnt >= T)  res += cnt;
                }

    //输出总面积
    printf("%d\n", res);

    return 0;
}
  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值