【PAT甲级 - C++题解】1055 The World‘s Richest

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1055 The World’s Richest (pintia.cn)
🔑中文翻译:世界首富
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1055 The World’s Richest

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤105) - the total number of people, and K (≤103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−106,106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None
题意

给定 N 个人的信息,每个人的信息输入格式如下:

姓名 年龄 净财产

现在给定 M 个询问,每个询问格式如下:

k a b

需要我们输出年龄范围在 [a,b] 之间排名前 k 的人。

排名规则先按照财产非递增进行排序,如果财产相等则按照年龄非递减排序,如果还相等则按照名字字典序升序排序。如果找不到符合要求的人,则输出 None

思路

这道题我们可以利用多路归并的思想解决,首先定义一个结构体用来存储每个人的信息,同时用一个二维数组 ages 来存储每个年龄段下有哪些人,对每个年龄段下的人进行排序,因此在每个年龄段下的第一个人一定是该年龄段里符合题目规则排名最高的那个。

然后,根据查询的年龄区间 ab 进行查找,每次都在 ages[a]ages[b] 中找到排名最高的那个人,为了避免同一个人被多次输出,这里我们用一个数组 idx 来进行标记。idx[i] 表示在 ages[i] 中,已经输出的人的数量为 idx[i] ,每次输出一个人的信息后,都要将对应的 idx[i]1 ,这样下次查找直接会从该人的后面那个人开始查找。

最后,需要判断该年龄段下是否能找到满足要求的人,如果找不到则输出 None

代码
#include<bits/stdc++.h>
using namespace std;

const int N = 210;
int n, k, idx[N];
//存储每个人的信息
struct Person
{
    string name;
    int age, w;
    //重载比较函数
    bool operator<(const Person& p)const
    {
        //先按w降序,再按age升序,最后按名字升序
        if (w != p.w)  return w > p.w;
        else if (age != p.age) return age < p.age;
        return name < p.name;
    }
};

//用来存储每个年龄的人
vector<Person> ages[N];

int main()
{
    //输入每个人的信息
    scanf("%d%d", &n, &k);
    char name[10];
    int age, w;
    for (int i = 0; i < n; i++)
    {
        scanf("%s%d%d", name, &age, &w);
        ages[age].push_back({ name,age,w });
    }

    //对每个年龄下的人进行排序
    for (auto& age : ages) sort(age.begin(), age.end());

    //开始询问
    for (int i = 1; i <= k; i++)
    {
        printf("Case #%d:\n", i);
        int cnt, a, b;
        scanf("%d%d%d", &cnt, &a, &b);

        memset(idx, 0, sizeof idx);
        bool exists = false;

        //采用多路归并算法
        while (cnt--)
        {
            //找到该年龄段内排序规则下最大那个人
            int t = -1;
            for (int i = a; i <= b; i++)
                if (idx[i] < ages[i].size())   //该年龄下是否还有人
                    if (t == -1 || ages[i][idx[i]] < ages[t][idx[t]])
                        t = i;

            if (t == -1) break;
            auto& p = ages[t][idx[t]];
            idx[t]++;
            printf("%s %d %d\n", p.name.c_str(), p.age, p.w);
            exists = true;
        }

        if (!exists) puts("None");
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值