Java—统计一篇英文文章中出现的不重复单词的个数

题目:

输入一篇英文文章,碰到"!!!"的时候停止,输出文章中出现的不重复单词的个数(注意:单词不区分大小写,如:The和the为一个单词)

输入格式:

一篇英文文章,以"!!!"结尾

输出格式:

不重复单词的个数

输入样例:

Unmanned aerial vehicles have been adopted in the inspection of violations Procurators will file public interest litigations against perpetrators who will need to replant trees take down illegal buildings control pollution and compensate environment-related losses  
The Yellow River is the second longest river in China It originates in the northwestern province of Qinghai and runs through nine provinces and autonomous regions in western central north and eastern China  
!!!!!

输出样例:

55

解析:

使用toLowerCase先将输入的单词都变为小写,再将单词都存入HashSet中,避免重复,最后输出HashSet.size()即为不重复单词的数量

答案:

import java.util.HashSet;
import java.util.Scanner;

public class Main {
	public static void main(String [] args){
		Scanner in=new Scanner(System.in);
		HashSet<String> passage=new HashSet<String>();
		String word;
		while(!(word=(in.next().toLowerCase())).equals("!!!!!")) {
			passage.add(word);
		}
		System.out.println(passage.size());
		}		
	}
  • 2
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值