poj 1837-Balance

11 篇文章 0 订阅
Balance
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 8971 Accepted: 5474

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

Source

此题大概意思就是在一个平衡杆(左右都是15格长度)挂满G个重物,最终使得杆平衡的方法数。想想有g个重物,重量不等,挂在w个位置上,当然位置是任意的,那么由于给出的g和w都是不大的数,此时就可以吧所有情况都用 一个合适的数组储存起来,这就用到了DP,将dp[i][j]表示挂i个物体后,平衡度为j的方法数,那么平衡度最大是多少呢?15*20*25=7500,(-7500,7500)那么就相当于i在1-15000之间,这样就明了,那么状态转化就应该是dp[i][j+w[i]*可挂位置=dp[i-1][j]。
#include<stdlib.h>
#include<stdio.h>
#include<string.h>
int main(){
    int c,g,dp[25][15005],p[25],w[25];
    while(scanf("%d%d",&c,&g)==2){
         for(int i=1;i<=c;i++)scanf("%d",&p[i]);
         for(int i=1;i<=g;i++)scanf("%d",&w[i]);
         memset(dp,0,sizeof(dp));
         dp[0][7500]=1;
         for(int i=1;i<=g;i++){
             for(int j=0;j<=15000;j++){
                 if(dp[i-1][j]){
                     for(int k=1;k<=c;k++)
                         dp[i][j+w[i]*p[k]]+=dp[i-1][j];
                 }
             }
         }
         printf("%d\n",dp[g][7500]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值