uva 10305 - Ordering Tasks

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100and mn is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance withn = m = 0 will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3
 
纯拓扑排序,我按着刘汝佳那个写的,哈哈学习了。
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define maxn 105
int topo[maxn],c[maxn],G[maxn][maxn],n,t;
bool dfs(int u){
     c[u]=-1; //-1表示正在访问中 
     for(int v=1;v<=n;v++)if(G[u][v])//查看是否存在关系 
     {
          if(c[v]<0)return false;
          if(!c[v]&&!dfs(v))return false;  
     } 
     c[u]=1;topo[--t]=u;//处理 
     return true;
}
bool toposort(){
     t=n;
     memset(c,0,sizeof(c));//初始化,0代表还未被访问 
     for(int i=1;i<=n;i++)
        if(!c[i]&&!dfs(i))return false;
     return true; 
}
int main(){
     int m,u,v;
     while(scanf("%d%d",&n,&m)==2&&(m||n)){
         memset(G,0,sizeof(G)); 
         for(int i=1;i<=m;i++){
             scanf("%d%d",&u,&v);
             G[u][v]=1; 
         }
         if(toposort()){//是否存在这样的拓扑排序,主要看有无有向环 
            for(int i=0;i<n-1;i++)printf("%d ",topo[i]);
            printf("%d\n",topo[n-1]); 
         } 
     }
     return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值