Ordering Tasks(拓扑排序)

John has  tasks to do. Unfortunately, the tasks are not independent and the execution of one task is  only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing  two integers, 100 and  m . is the number of tasks (numbered from 1 to  n )and  is the  number of direct precedence relations between tasks. After this, there will be  lines with two integers  and  , representing the fact that task  i
must be executed before task  j . An instance with  = 0 will n is h the input.
Output
For each instance, print a line with  n
integers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
Sample Output
1 4 2 5 3

题意
john 有n个任务要完成,但是每个任务完成有先后顺序,即完成一个任务必须先完成他的准备任务;
第一行 输入任务数量 n ,任务先后关系 m

代码如下

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int n,m;
int map[150][150];     //存放关系矩阵
int book[150][150];    //记录之前是否存过,防止重复存关系,造成入度增加
int r[150];            //记录点的入度
int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        if(n==0&&m==0) break;
        memset(map,0,sizeof(map));     //初始化为0
        memset(book,0,sizeof(book));
        memset(r,0,sizeof(r));
        int i;
        for(i=0;i<m;i++){              //读入关系
            int a,b;
            scanf("%d%d",&a,&b);
            if(book[a][b]==0){
                map[a][b]=1;
                r[b]++;
            }
        }
        queue<int>p;
        for(i=1;i<=n;i++){        //此题是 先入度为0 的点优先 后小的点优先 因此要用到队列
            if(r[i]==0)
                p.push(i);
        }
        int cnt=0;
        int t[150];
        while(!p.empty()){
            int temp=p.front();
            p.pop();
            t[cnt++]=temp;
            int j;
            for(j=1;j<=n;j++){
                if(map[temp][j]==1){
                    r[j]--;
                    if(r[j]==0)
                        p.push(j);
                }
            }
        }
        for(i=0;i<cnt-1;i++)
            printf("%d ",t[i]);
        printf("%d\n",t[i]);
    }
return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Guava Ordering是一个用于排序的工具类,它为构建复杂的比较器提供了一种流畅的风格。通过使用Guava Ordering,我们可以根据自定义的规则对集合中的元素进行排序。 在Guava Ordering中,有三种静态方法用于创建Ordering排序器:natural()、usingToString()和from(Comparator)。natural()方法使用自然排序规则生成排序器,即从小到大的顺序。usingToString()方法根据元素的toString()方法返回值进行排序。from(Comparator)方法根据给定的Comparator生成排序器。 创建Ordering排序器后,可以使用它对集合或元素进行操作。常见的方法包括sortedCopy(List)、immutableSortedCopy(Iterable)、min(E, E)和max(E, E)等。sortedCopy(List)方法返回一个已排序的List副本,immutableSortedCopy(Iterable)方法返回一个不可变的已排序集合,min(E, E)方法返回两个元素中较小的那个,max(E, E)方法返回两个元素中较大的那个。 下面是一个示例代码,展示了如何使用Guava Ordering对People类的age属性进行排序: List<People> peopleList = new ArrayList<People>() { { add(new People("A", 33)); add(new People("B", 11)); add(new People("C", 18)); } }; Ordering<People> ordering = Ordering.natural().onResultOf(new Function<People, Comparable>() { @Override public Comparable apply(People people) { return people.getAge(); } }); for (People p : ordering.sortedCopy(peopleList)) { System.out.println(MoreObjects.toStringHelper(p) .add("name", p.getName()) .add("age", p.getAge())); } 这段代码中,我们首先创建了一个包含People对象的List。然后使用Ordering.natural().onResultOf()方法创建了一个排序器,该排序器按照People对象的age属性进行排序。最后,我们通过ordering.sortedCopy()方法将集合按照排序规则进行排序,并打印排序后的结果。 通过使用Guava Ordering,我们可以轻松地实现各种排序需求,并且可以方便地链式调用方法来定制和增强现有的比较器。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值