HDU6027(快速幂)(水)

Easy Summation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1329    Accepted Submission(s): 538


Problem Description
You are encountered with a traditional problem concerning the sums of powers.
Given two integers  n  and  k . Let  f(i)=ik , please evaluate the sum  f(1)+f(2)+...+f(n) . The problem is simple as it looks, apart from the value of  n  in this question is quite large.
Can you figure the answer out? Since the answer may be too large, please output the answer modulo  109+7 .
 

Input
The first line of the input contains an integer  T(1T20) , denoting the number of test cases.
Each of the following  T  lines contains two integers  n(1n10000)  and  k(0k5) .
 

Output
For each test case, print a single line containing an integer modulo  109+7 .
 

Sample Input
  
  
3 2 5 4 2 4 1
 

Sample Output
  
  
33 30 10
 

#include<cstdio>
#include<iostream>
#include<cstring>
#include<string.h>
using namespace std;
typedef long long ll;
int n,k;
ll ans;
const ll MOD=1e9+7;
ll fsm(ll a,int b)
{
	ll res=1;
	while(b>0)
	{
		if(b&1)
			res=(res*a)%MOD;
		a=(a*a)%MOD;
		b>>=1;
	}
	return res;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		ans=0;
		scanf("%d%d",&n,&k);
		for(int i=1;i<=n;i++)
		{
			ans=(ans+fsm(i,k))%MOD;	
		}	
		printf("%lld\n",ans);
	}
	
	
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值