hdu4221(贪心)

Greedy?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2583    Accepted Submission(s): 870


Problem Description
iSea is going to be CRAZY! Recently, he was assigned a lot of works to do, so many that you can't imagine. Each task costs Ci time as least, and the worst news is, he must do this work no later than time Di!
OMG, how could it be conceivable! After simple estimation, he discovers a fact that if a work is finished after Di, says Ti, he will get a penalty Ti - Di. Though it may be impossible for him to finish every task before its deadline, he wants the maximum penalty of all the tasks to be as small as possible. He can finish those tasks at any order, and once a task begins, it can't be interrupted. All tasks should begin at integral times, and time begins from 0.
 

Input
The first line contains a single integer T, indicating the number of test cases.
Each test case includes an integer N. Then N lines following, each line contains two integers Ci and Di.

Technical Specification
1. 1 <= T <= 100
2. 1 <= N <= 100 000
3. 1 <= Ci, Di <= 1 000 000 000
 

Output
For each test case, output the case number first, then the smallest maximum penalty.
 

Sample Input
  
  
2 2 3 4 2 2 4 3 6 2 7 4 5 3 9
 

Sample Output
  
  
Case 1: 1 Case 2: 3
 

Author
iSea@WHU
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   4224  4223  4219  4218  4217 

#include<cstdio>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
struct node{
	int ci;
	int di;
}task[100010];
bool cmp(node a,node b)
{
	return a.di<b.di;
}
int main()
{
	int t;
	int n;
	int cas=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&task[i].ci,&task[i].di);
		}
		ll res;
		ll ans;
		res=0;
		ans=0;
		sort(task,task+n,cmp);
		for(int i=0;i<n;i++)
		{
			res+=task[i].ci;
			if(ans<res-task[i].di)
				ans=res-task[i].di;
		}
		cout<<"Case "<<cas<<": ";
		printf("%lld\n",ans);
		cas++;
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值