hdu4221 Greedy

Greedy?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2866    Accepted Submission(s): 945


Problem Description
iSea is going to be CRAZY! Recently, he was assigned a lot of works to do, so many that you can't imagine. Each task costs Ci time as least, and the worst news is, he must do this work no later than time Di!
OMG, how could it be conceivable! After simple estimation, he discovers a fact that if a work is finished after Di, says Ti, he will get a penalty Ti - Di. Though it may be impossible for him to finish every task before its deadline, he wants the maximum penalty of all the tasks to be as small as possible. He can finish those tasks at any order, and once a task begins, it can't be interrupted. All tasks should begin at integral times, and time begins from 0.
 

Input
The first line contains a single integer T, indicating the number of test cases.
Each test case includes an integer N. Then N lines following, each line contains two integers Ci and Di.

Technical Specification
1. 1 <= T <= 100
2. 1 <= N <= 100 000
3. 1 <= Ci, Di <= 1 000 000 000
 

Output
For each test case, output the case number first, then the smallest maximum penalty.
 

Sample Input
 
 
223 42 243 62 74 53 9
 

Sample Output
 
 
Case 1: 1Case 2: 3
 

Author
// if a work is finished after Di, says Ti, he will get a penalty Ti - Di. 
//意思是 如果一个工作在Di天之后,即Ti天完成,那么惩罚是Ti-Di 
#include<stdio.h>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
const int MAXN=100010;
struct Node
{
    int c,d;
}node[MAXN];

bool cmp(Node a,Node b)
{
    return a.d<b.d;//优先处理截止时间最早的任务 
}
//所有任务的最大惩罚尽可能小 
int main()
{
    int T;
    int iCase=0;
    scanf("%d",&T);
    int n;
    while(T--)
    {
        iCase++;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        scanf("%d%d",&node[i].c,&node[i].d);
        sort(node,node+n,cmp);
        
        long long sum=0;
        long long ans=0;
        long long ipenalty;
        for(int i=0;i<n;i++)//遍历每一个任务。
        {
            sum += node[i].c; //sum记录当前花费时间 
            ipenalty = sum-node[i].d;//peni代表当前任务i的惩罚 
            if(ipenalty>ans)//题意是要记录最大的一次惩罚,而不是把所有惩罚相加 
			ans=sum-node[i].d;
        }
        printf("Case %d: %I64d\n",iCase,ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值