ZOJ Problem 3946 (SPFA)

Edward, the emperor of the Marjar Empire, wants to build some bidirectional highways so that he can reach other cities from the capital as fast as possible. Thus, he proposed the highway project.

The Marjar Empire has N cities (including the capital), indexed from 0 to N - 1 (the capital is 0) and there are M highways can be built. Building the i-th highway costs Ci dollars. It takes Di minutes to travel between city Xi and Yi on the i-th highway.

Edward wants to find a construction plan with minimal total time needed to reach other cities from the capital, i.e. the sum of minimal time needed to travel from the capital to city i (1 ≤ i ≤ N). Among all feasible plans, Edward wants to select the plan with minimal cost. Please help him to finish this task.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first contains two integers N, M (1 ≤ N, M ≤ 105).

Then followed by M lines, each line contains four integers Xi, Yi, Di, Ci (0 ≤ Xi, Yi < N, 0 < Di, Ci < 105).

Output

For each test case, output two integers indicating the minimal total time and the minimal cost for the highway project when the total time is minimized.

Sample Input

2
4 5
0 3 1 1
0 1 1 1
0 2 10 10
2 1 1 1
2 3 1 2
4 5
0 3 1 1
0 1 1 1
0 2 10 10
2 1 2 1
2 3 1 2
Sample Output

4 3
4 4

题解:
(1)用邻接表adjlist存图
(2)用dtime,dcost分别储存最短时间,最小开销估计值
(3)采取动态逼近法:设立一个先进先出的队列用来保存待优化的结点,优化时每次取出队首结点u,并且用u点当前的最短路径估计值对离开u点所指向的结点v进行松弛操作,如果v点的最短路径估计值有所调整,且v点不在当前的队列中,就将v点放入队尾。这样不断从队列中取出结点来进行松弛操作,直至队列空为止。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <vector>
#include <queue>
using namespace std;

typedef long long LL;
const int SIZE = 1E5 + 10;

class Edge {
public:
  int to;
  LL t, c;
  Edge(int a1, LL a2, LL a3) {
    to = a1; t = a2; c = a3; 
  }
};

int t, n, m;
LL dtime[SIZE], dcost[SIZE];
bool vis[SIZE];
vector<Edge> adjlist[SIZE];

void Init () {
  for (int i = 0; i < SIZE; ++i) {
    adjlist[i].clear();
  }
  memset(vis, 0, sizeof(vis));
  memset(dtime, 0x3f, sizeof(dtime));
  memset(dcost, 0x3f, sizeof(dcost));
}

void Spfa() {
  dtime[0] = dcost[0] = 0;
  queue<int> q;
  q.push(0);
  while (!q.empty()) {
    int head = q.front(); q.pop(); vis[head] = false;
    for (int i = 0; i < adjlist[head].size(); ++i) {
      int to = adjlist[head][i].to;
      LL t = adjlist[head][i].t;
      LL c = adjlist[head][i].c;
      if (dtime[to] > dtime[head] + t || dtime[to] == dtime[head] + t && dcost[to] > c) {
        dtime[to] = dtime[head] + t;
        dcost[to] = c;
        if (!vis[to]) {
          vis[to] = true;
          q.push(to);
        }
      }
    }
  }
  LL sumTime = 0, sumCost = 0;
  for (int i = 0; i < n; ++i) {
    sumTime += dtime[i];
    sumCost += dcost[i];
  }
  printf("%lld %lld\n", sumTime, sumCost);
}

int main() {
#ifndef ONLINE_JUDGE
  freopen("in.txt", "r", stdin);
#endif
  scanf("%d", &t);
  while (t--) {
    Init();
    scanf("%d%d", &n, &m);
    for (int i = 0; i < m; ++i) {
      int a, b;
      LL c, d;
      scanf("%d%d%lld%lld", &a, &b, &c, &d);
      adjlist[a].push_back(Edge(b, c, d));
      adjlist[b].push_back(Edge(a, c, d));
    }
    Spfa();
  }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值