ZOJ 3946-Highway Project【最短路的应用】(2016浙江省大学生程序设计竞赛)

Highway Project

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Edward, the emperor of the Marjar Empire, wants to build some bidirectional highways so that he can reach other cities from the capital as fast as possible. Thus, he proposed the highway project.

The Marjar Empire has N cities (including the capital), indexed from 0 toN - 1 (the capital is 0) and there areM highways can be built. Building thei-th highway costs Ci dollars. It takes Di minutes to travel between cityXi andYi on the i-th highway.

Edward wants to find a construction plan with minimal total time needed to reach other cities from the capital, i.e. the sum of minimal time needed to travel from the capital to cityi (1 ≤iN). Among all feasible plans, Edward wants to select the plan with minimal cost. Please help him to finish this task.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first contains two integers N, M (1 ≤ N, M ≤ 105).

Then followed by M lines, each line contains four integers Xi,Yi,Di, Ci (0 ≤Xi, Yi < N, 0 < Di,Ci < 105).

Output

For each test case, output two integers indicating the minimal total time and the minimal cost for the highway project when the total time is minimized.

Sample Input
2
4 5
0 3 1 1
0 1 1 1
0 2 10 10
2 1 1 1
2 3 1 2
4 5
0 3 1 1
0 1 1 1
0 2 10 10
2 1 2 1
2 3 1 2
Sample Output
4 3

4 4

解题思路:

给出一张图,边无向有两个,两个权分别为路的消耗的时间和花费的经前,点编号0-n-1,现在要你求从0建立到其他的路径,使各点花费总时间最少优先的情况下花费的金钱也最少。就是要考虑都是最短的情况下,谁的花费最少。

#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const ll inf=0x3f3f3f3f;
const ll maxn=100005;
ll edgenum,vis[maxn],head[maxn],dist[maxn],cost[maxn];
struct node
{
	ll from,to,len,val;
	ll next;
}edge[maxn*5];
void init()
{
	edgenum=0;
	memset(head,-1,sizeof(head));
	memset(dist,inf,sizeof(dist));
	memset(vis,0,sizeof(vis));
	memset(cost,inf,sizeof(cost));
}
void add(ll u,ll v,ll d,ll c)
{
	node tp={u,v,d,c,head[u]};
	edge[edgenum]=tp;
	head[u]=edgenum++;
}
void dijkstra(ll n,ll st)
{
	queue<ll> q;
	q.push(st);
	vis[st]=1;
	dist[st]=0;
	while(!q.empty())
	{
		ll v=q.front();q.pop();
		vis[v]=0;
		for(ll i=head[v];i!=-1;i=edge[i].next)
		{
			ll u=edge[i].to;
			if(dist[edge[i].to]==dist[v]+edge[i].len&&edge[i].val<cost[edge[i].to])
			{
				cost[edge[i].to]=edge[i].val;
			}
			if(dist[edge[i].to]>dist[v]+edge[i].len)
			{
				dist[edge[i].to]=dist[v]+edge[i].len;
				cost[edge[i].to]=edge[i].val;
				if(!vis[edge[i].to])
				{
					vis[edge[i].to]=1;
					q.push(edge[i].to);
				}
			}
		}
	}
}
int main()
{
	//freopen("shuju.txt","r",stdin);
	ll t;
	scanf("%lld",&t);
	while(t--)
	{
		ll n,m;
		scanf("%lld%lld",&n,&m);
		init();
		for(ll i=0;i<m;++i)
		{
			ll u,v,d,c;
			scanf("%lld%lld%lld%lld",&u,&v,&d,&c);
			add(u,v,d,c);add(v,u,d,c);
		}
		ll minlenth=0,mincost=0;
		dijkstra(n,0);
		for(ll i=1;i<n;++i)
		{
			minlenth+=dist[i];
			mincost+=cost[i];
		}
		printf("%lld %lld\n",minlenth,mincost);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值