POJ3616

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

  • Line 1: Three space-separated integers: N, M, and R
  • Lines 2..M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

  • Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

我看别人都说两重循环非要TLE
我就不信这个邪….
两重循环16ms一样过~~~~
我偏要DP他的时间….
dp代表的是他的每一刻的最大牛奶数
只要把他自己和他的前一个比,并且和以他为结尾的区间减掉空闲时间之前的那个最大值比就可以….
就是1000000+1000的复杂度…
难道有人每次都遍历一遍所有的m?
可以….很强势
开始的时候先给他排一遍序
1000的nlogn也没有多少….
根本就是忽略不计

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
struct p
{
    int s, d, z;
    bool operator <(const p &a)const {
        if (d != a.d)return d < a.d;
        else return s < a.s;
    }
};
p zhi[1001];
int dp[1000001];
int main()
{
    int n, m, r;
    while (cin >> n >> m >> r)
    {
        int q, w, e;
        for (int a = 1;a <= m;a++)
        {
            scanf("%d%d%d", &q, &w, &e);
            zhi[a] = { q,w,e };
        }
        sort(zhi+1, zhi + m+1);
        int b = 1;
        int sum = 0;
        for (int a = 1;a <= n;a++)
        {
            while (zhi[b].d == a&&b<=m)
            {
                if (zhi[b].s - r <= 0)dp[a] = max(dp[a], zhi[b].z);
                else dp[a] = max(dp[zhi[b].s - r] + zhi[b].z,dp[a]);
                sum = max(sum, dp[a]);
                b++;
            }
            dp[a] = max(dp[a], dp[a - 1]);
            sum = max(sum, dp[a]);
        }
        cout << sum << endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值