HDU2196 终于不是水题的树形dp啦哈哈哈哈哈哈

Description
A school bought the first computer some time ago(so this computer’s id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.

Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
Sample Input
5
1 1
2 1
3 1
1 1
Sample Output
3
2
3
4
4

这个题要dp两次
第一次就是把每个节点的子树最长,第二长,以及其坐标都要算出来
但是这个第二长是有个前提的那就是不能经过同一个子节点….
这地方就疯狂的错……..
坑….
第二次就是把每个节点他和父节点的联系以及父节点的最长或第二长的和比较,来确定长度。。。
如果父节点的最长和子节点在同一条上那就用第二长….
如果比较完以后没有更新最长
那么别忘了和第二长比较,可以更新第二长….
很简单就能想到,因为单链的树的第二长都是0,怎么可能呢?
又是坑….
总之这题好麻烦……
不过做完了感觉很爽

#include<iostream>
#include<vector>
#include<memory.h>
#include<algorithm>
using namespace std;
int n;
struct p
{
    long long  weizhi,zhi;
};
struct q
{
    long long dabiao,xiaobiao,dazhi,xiaozhi;
};
vector<p> li[10001];
int geshu[10001],geshu1[10001];
bool biaoji[10001];
q dp[10001];
int tree[10001];
void dfs(int gen)
{
    if(geshu[gen]==0)return;
    biaoji[gen]=1;
    int shu=li[gen].size();
    long long das=0,xis=0,dab=0,xib=0;
    for(int a=0;a<shu;a++)
    {
        if(biaoji[li[gen][a].weizhi]==0)
        {
            tree[li[gen][a].weizhi]=gen;
            geshu[li[gen][a].weizhi]--;
            dfs(li[gen][a].weizhi);
            if(das<=dp[li[gen][a].weizhi].dazhi+li[gen][a].zhi)
            {
                xis=das;
                xib=dab;
                dab=li[gen][a].weizhi;
                das=dp[li[gen][a].weizhi].dazhi+li[gen][a].zhi;
            }
            else
            {
                if(xis<=dp[li[gen][a].weizhi].dazhi+li[gen][a].zhi)
                {
                    xis=dp[li[gen][a].weizhi].dazhi+li[gen][a].zhi;
                    xib=li[gen][a].weizhi;
                }
            }
        }
    }
    dp[gen]={dab,xib,das,xis};
}
void dfs1(int gen,int die)
{
    if(tree[gen]!=0)
    {
        if(gen!=dp[tree[gen]].dabiao)
        {   
            if(dp[gen].dazhi<=dp[tree[gen]].dazhi+li[tree[gen]][die].zhi)
            {
                dp[gen].xiaozhi=dp[gen].dazhi;
                dp[gen].xiaobiao=dp[gen].dabiao;
                dp[gen].dazhi=dp[tree[gen]].dazhi+li[tree[gen]][die].zhi;
                dp[gen].dabiao=tree[gen];
            }
            else
            {
                if(dp[gen].xiaozhi<=dp[tree[gen]].dazhi+li[tree[gen]][die].zhi)
                {
                    dp[gen].xiaozhi=dp[tree[gen]].dazhi+li[tree[gen]][die].zhi;
                    dp[gen].xiaobiao=tree[gen];
                }
            }
        }
        else
        {
            if(dp[gen].dazhi<=dp[tree[gen]].xiaozhi+li[tree[gen]][die].zhi)
            {
                dp[gen].xiaozhi=dp[gen].dazhi;
                dp[gen].xiaobiao=dp[gen].dabiao;
                dp[gen].dazhi=dp[tree[gen]].xiaozhi+li[tree[gen]][die].zhi;
                dp[gen].dabiao=tree[gen];
            }
            else
            {
                if(dp[gen].xiaozhi<=dp[tree[gen]].xiaozhi+li[tree[gen]][die].zhi)
                {
                    dp[gen].xiaozhi=dp[tree[gen]].xiaozhi+li[tree[gen]][die].zhi;
                    dp[gen].xiaobiao=tree[gen];
                }
            }
        }
    }
    if(geshu1[gen]==0)return;
    biaoji[gen]=1;
    int shu=li[gen].size();
    for(int a=0;a<shu;a++)
    {
        if(biaoji[li[gen][a].weizhi]==0)
        {
            geshu1[li[gen][a].weizhi]--;
            dfs1(li[gen][a].weizhi,a);
        }
    }
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    while(cin>>n)
    {
        int l,r;
        memset(geshu,0,sizeof(geshu));
        memset(biaoji,0,sizeof(biaoji));
        memset(dp,0,sizeof(dp));
        memset(tree,0,sizeof(tree));
        for(int a=1;a<=n;a++)li[a].clear();
        for(int a=2;a<=n;a++)
        {
            cin>>l>>r;
            li[a].push_back({l,r});
            li[l].push_back({a,r});
            geshu[a]++;
            geshu1[a]++;
            geshu[l]++;
            geshu1[l]++;
        }
        dfs(1);
        tree[1]=0;
        memset(biaoji,0,sizeof(biaoji));
        dfs1(1,0);
        for(int a=1;a<=n;a++)cout<<dp[a].dazhi<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值