poj3255 次短路裸题

Description
Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input
Line 1: Two space-separated integers: N and R
Lines 2.. R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output
Line 1: The length of the second shortest path between node 1 and node N
Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100
Sample Output
450

次短路其实就是最短路的板子改改…
当新的路比最短路还短那么更新最短路,次短路更新成原来的最短路
当新的路比最短路要长比次短路要短那么更新次短路
所有的边全部扔进优先队列…

新的路不管是次短路还是最短路全部都扔进去更新

#include<iostream>
#include<vector>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
vector<int>tu[5001],juli[5001];
int yijing[5001][2];
long long daon[5001][2];
int inf=0x3f3f3f3f;
struct p
{
    long long dian,chang,biaoji;
    p (long long diann = 0, long long changg = 0,long long biaojii=0) : dian(diann), chang(changg),biaoji(biaojii) {}
    bool operator< (const p&a)const{
        return chang>a.chang;
    }
};
int main()
{
    #define int long long
    int n,m;
    cin>>n>>m;
    int q,w,e;
    memset(daon,0x3f,sizeof(daon));
    memset(yijing,0,sizeof(yijing));
    for(int a=1;a<=m;a++)
    {
        scanf("%d%d%d",&q,&w,&e);
        tu[q].push_back(w);
        tu[w].push_back(q);
        juli[q].push_back(e);
        juli[w].push_back(e);   
    }
    priority_queue<p>qq;
    qq.push(p(1,0,0));
    daon[1][0]=0;
    while(!qq.empty())
    {
        p zas=qq.top();
        qq.pop();
        if(yijing[zas.dian][zas.biaoji])continue;
        yijing[zas.dian][zas.biaoji]=1;
        for(int a=0;a<tu[zas.dian].size();a++)
        {
            if(!yijing[tu[zas.dian][a]][0]&&daon[tu[zas.dian][a]][0]>daon[zas.dian][zas.biaoji]+juli[zas.dian][a])
            {
                daon[tu[zas.dian][a]][1]=daon[tu[zas.dian][a]][0];
                daon[tu[zas.dian][a]][0]=daon[zas.dian][0]+juli[zas.dian][a];
                qq.push(p(tu[zas.dian][a],daon[tu[zas.dian][a]][0],0));
                qq.push(p(tu[zas.dian][a],daon[tu[zas.dian][a]][1],1));
            }
            else if(!yijing[tu[zas.dian][a]][1]&&daon[tu[zas.dian][a]][1]>daon[zas.dian][zas.biaoji]+juli[zas.dian][a])
            {
                daon[tu[zas.dian][a]][1]=daon[zas.dian][zas.biaoji]+juli[zas.dian][a];
                qq.push(p(tu[zas.dian][a],daon[tu[zas.dian][a]][1],1));
            }
        }
    }
    cout<<daon[n][1]<<endl;
    return 0;
}
1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值