poj3694 LCA+并查集+tarjan求割边

8 篇文章 0 订阅
5 篇文章 0 订阅

Description
A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can’t be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input
The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output
For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input
3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0
Sample Output
Case 1:
1
0

Case 2:
2
0

这个题一开始就是用tarjan求一下dfn和low
作用就是缩点
把没用的点全部缩成同一个
首先割边就是一棵树的树枝
所以在询问的时候将两个点连起来减掉的割边就是各自到最近公共祖先的全部边
并查集用在这里主要意义是看他们是否在一个环中,每个环自己是一个集合。

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<vector>
using namespace std;
vector<int>tu[100001];
int dfn[100001], low[100001], clj, jc, die[100001], bcj[100001], zouguo[100001],qiao[100001];
int zhao(int x)
{
    return bcj[x] == -1 ? x : bcj[x] = zhao(bcj[x]);
}
void hebing(int a, int b)
{
    int q = zhao(a), w = zhao(b);
    if (q != w)bcj[q] = w;
}
void tarjan(int dian, int ba)
{
    dfn[dian] = low[dian] =++clj;
    die[dian] = ba;
    for (int a = 0; a<tu[dian].size(); a++)
    {
        if (!dfn[tu[dian][a]])
        {
            tarjan(tu[dian][a], dian);
            low[dian] = min(low[dian], low[tu[dian][a]]);
            if (low[tu[dian][a]] <= dfn[dian])hebing(tu[dian][a], dian);
            else jc++,qiao[tu[dian][a]]=1;
        }
        else if (tu[dian][a] != ba)low[dian] = min(low[dian], dfn[tu[dian][a]]);
    }
}
void ceshi(int u)
{
    int x = zhao(u), xx = zhao(die[u]);
    if (x != xx&&qiao[u])
    {
        jc--;
        qiao[u] = 0;
        bcj[x] = xx;
    }
}
void lca(int q, int w)
{
    while (dfn[q]>dfn[w])
    {
        ceshi(q);
        q = die[q];
    }
    while (dfn[q]<dfn[w])
    {
        ceshi(w);
        w = die[w];
    }
    while (q != w)
    {
        ceshi(q), ceshi(w);
        q = die[q], w = die[w];
    }
}
int main()
{
    int n, m, k;
    int u = 0;
    while (cin >> n >> m)
    {
        if (n == 0 && m == 0)break;
        clj = 0, jc = 0;
        memset(dfn, 0, sizeof(dfn));
        memset(zouguo, 0, sizeof(zouguo));
        memset(low, 0, sizeof(low));
        //memset(die, 0, sizeof(die));
        memset(bcj, -1, sizeof(bcj));
        for (int a = 1; a <= n; a++)tu[a].clear();
        int q, w;
        for (int a = 1; a <= m; a++)
        {
            scanf("%d%d", &q, &w);
            tu[q].push_back(w);
            tu[w].push_back(q);
        }
        tarjan(1, 0);
        //cout << jc << endl;
        cin >> k;
        printf("Case %d:\n", ++u);
        for (int a = 1; a <= k; a++)
        {
            scanf("%d%d", &q, &w);
            if (zhao(q) != zhao(w))lca(q, w);
            printf("%d\n", jc);
        }
        cout << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值