POJ3694 Network (LCA+tarjan+并查集)

7 篇文章 0 订阅

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ AB ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ ABN), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0

题意,前两个数给出无向图的点和边,后几行给出无向图的边,在给出一个数,为要添加的边数,后几行给出要添加的边。求每一条边添加完后图中的桥数。

思路:跑一遍tarjan,找出桥,用并查集记录每一个块。找出添加边的最近公共祖先,当前桥的点到最近公共祖先的桥全部连接,用并查集记录。输出剩下的桥的数量。

#include<algorithm>
#include<string.h>
#include<stdio.h>
#include<math.h>
using namespace std;
struct path
{
    int to,nextt;
}A[400010];
int head[100010],DFN[100010],LOW[100010],pre[100010],f[100010];
int tot,indox,ans,carry,n,m,x,y;
void init()
{
    tot=indox,ans,carry=0;
    memset(head,0,sizeof(head));
    memset(DFN,-1,sizeof(DFN));
    memset(LOW,-1,sizeof(LOW));
    for(int i=1;i<=n;i++)
        f[i]=i;
    return ;
}
void add(int u,int v)
{
    ++tot;
    A[tot].to=v;
    A[tot].nextt=head[u];
    head[u]=tot;
    return ;
}
int Find(int x)
{
    if(x!=f[x]) f[x]=Find(f[x]);
    return f[x];
}
int ADT(int u,int v)
{
    int p1=Find(u),p2=Find(v);
    if(p1==p2)
        return false;
    f[p1]=p2;
    return true;
}
void tarjan(int u,int p)
{
    DFN[u]=LOW[u]=++indox;
    int tem;
    for(int i=head[u];i;i=A[i].nextt)
    {
        tem=A[i].to;
        if(tem==p) continue;
        if(DFN[tem]==-1)
        {
            pre[tem]=u;
            tarjan(tem,u);
            LOW[u]=min(LOW[u],LOW[tem]);
            if(LOW[tem]>DFN[u])
            {
                ans++;
            }
            else ADT(u,tem);
        }
        else LOW[u]=min(LOW[u],DFN[tem]);
    }
    return ;
}
void slove(int u,int v)
{
    if(DFN[v]<DFN[u]) swap(u,v);
    while(DFN[u]<DFN[v])
    {
        if(ADT(v,pre[v]))
            ans--;
        v=pre[v];
    }
    while(u!=v)
    {
        if(ADT(u,pre[u]))
            ans--;
        u=pre[u];
    }
    return ;
}
int main()
{
    while(~scanf("%d%d",&n,&m),n||m)
    {
        init();
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d",&x,&y);
            add(x,y);
            add(y,x);
        }
        f[1]=1;
        tarjan(1,1);
        scanf("%d",&m);
        printf("Case %d:\n",++carry);
        while(m--)
        {
            scanf("%d%d",&x,&y);
            slove(x,y);
            printf("%d\n",ans);
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值