HDU3306

As we all known , the Fibonacci series : F(0) = 1, F(1) = 1, F(N) = F(N - 1) + F(N - 2) (N >= 2).Now we define another kind of Fibonacci : A(0) = 1 , A(1) = 1 , A(N) = X * A(N - 1) + Y * A(N - 2) (N >= 2).And we want to Calculate S(N) , S(N) = A(0) 2 +A(1) 2+……+A(n) 2.

Input
There are several test cases.
Each test case will contain three integers , N, X , Y .
N : 2<= N <= 2 31 – 1
X : 2<= X <= 2 31– 1
Y : 2<= Y <= 2 31 – 1
Output
For each test case , output the answer of S(n).If the answer is too big , divide it by 10007 and give me the reminder.
Sample Input
2 1 1
3 2 3
Sample Output
6
196

裸地矩阵快速幂
虽然是这样不过推还是用了很久。。

#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
#include<map>
#include<cstring>
#include<cstdio>
using namespace std;
int mo = 10007;
struct p
{
    int q[4][4];
};
p cheng(p q, p w)
{
    p fh;
    for (int a = 0; a < 4; a++)
    {
        for (int b = 0; b < 4; b++)
        {
            fh.q[a][b] = 0;
            for (int c = 0; c < 4; c++)
            {
                fh.q[a][b] += (q.q[a][c]%mo * w.q[c][b]%mo+mo ) % mo;
                fh.q[a][b] = (fh.q[a][b]+mo) % mo;
            }
        }
    }
    return fh;
}
p ksm(p ds, int zs)
{
    p fs;
    for (int a = 0; a < 4; a++)
    {
        for (int b = 0; b < 4; b++)
        {
            if (a != b)fs.q[a][b] = 0;
            else fs.q[a][b] = 1;
        }
    }
    while (zs)
    {
        if (zs & 1)fs = cheng(fs, ds);
        ds = cheng(ds, ds);
        zs >>= 1;
    }
    return fs;
}
int  main()
{
    int n, x, y;
    while (scanf("%d%d%d", &n, &x, &y) == 3)
    {
        x %= mo, y %= mo;
        p ds = { {1,x*x%mo,y*y%mo,2*x*y%mo,0,x*x%mo,y*y%mo,2*x*y%mo,0,1,0,0,0,x,0,y} };
        ds = ksm(ds, n - 1);
        printf("%d\n",(2*ds.q[0][0]%mo + ds.q[0][1]%mo + ds.q[0][2]%mo + ds.q[0][3]%mo+4*mo ) % mo );
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值