The story happened long long ago. One day, Cao Cao made a special order called “Chicken Rib” to his army. No one got his point and all became very panic. However, Cao Cao himself felt very proud of his interesting idea and enjoyed it.
Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army. Cao Cao got very angry at his cleverness and would like to punish Xiu Yang. But how can you punish someone because he’s clever? By looking at the chicken rib, he finally got a new idea to punish Xiu Yang.
He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only use one stick as the container.
Formally, we can treat the container stick as an LL length segment. And the gold sticks as segments too. There were many gold sticks with different length aiai and value vivi. Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. Luckily, Xiu Yang came up with a good idea. On the two sides of the container, he could make part of the gold sticks outside the container as long as the center of the gravity of each gold stick was still within the container. This could help him get more valuable gold sticks.
As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So no one knows how many gold sticks Xiu Yang made it in the container.
Can you help solve the mystery by finding out what’s the maximum value of the gold sticks Xiu Yang could have taken?
Input
The first line of the input gives the number of test cases, T(1≤T≤100)T(1≤T≤100). TT test cases follow. Each test case start with two integers, N(1≤N≤1000)N(1≤N≤1000) and L(1≤L≤2000)L(1≤L≤2000), represents the number of gold sticks and the length of the container stick. NN lines follow. Each line consist of two integers, ai(1≤ai≤2000)ai(1≤ai≤2000) and vi(1≤vi≤109)vi(1≤vi≤109), represents the length and the value of the ithith gold stick.
Output
For each test case, output one line containing Case #x: y, where xx is the test case number (starting from 1) and yy is the maximum value of the gold sticks Xiu Yang could have taken.
Sample Input
4
3 7
4 1
2 1
8 1
3 7
4 2
2 1
8 4
3 5
4 1
2 2
8 9
1 1
10 3
Sample Output
Case #1: 2
Case #2: 6
Case #3: 11
Case #4: 3
这个题还有一种是先贪心的
这个背包题明确了每次转移的意义
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
//对同一个物品多种状态的01背包
// 只要对同一种状态/重量进行多次判断
//一定只是转移其中一个
long long dp[5000][3],zhong[1001],zhi[1001];
int main()
{
long long T = 0, u = 0,n,m;
cin >> T;
while (T--)
{
cin >> n>>m;
for (long long a = 1; a <= n; a++)scanf("%lld%lld", &zhong[a], &zhi[a]);
for (long long a = 1; a <= n; a++)zhong[a] *= 2;
memset(dp, 0, sizeof(dp));
m *= 2;
long long dan = 0;
for (long long a = 1; a <= n; a++)
{
if (zhong[a] >= 2 * m)
{
dan = max(dan, zhi[a]);
continue;
}
for (long long b = m; b>=0; b--)
{
for (long long c = 2; c >=0; c--)
{
if (b - zhong[a] / 2 < 0)continue;
if (b - zhong[a] >= 0)dp[b][c] = max(dp[b - zhong[a]][c] + zhi[a], dp[b][c]);
if (!c)continue;
dp[b][c] = max(dp[b - zhong[a] / 2][c - 1] + zhi[a],dp[b][c]);
}
}
}
for (long long a = 0; a < 3; a++)dan = max(dp[m][a],dan);
printf("Case #%lld: %lld\n", ++u, dan);
}
}