Pick The Sticks
Time Limit: 15000/10000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)Total Submission(s): 1336 Accepted Submission(s): 443
Problem Description
The story happened long long ago. One day, Cao Cao made a special order called "Chicken Rib" to his army. No one got his point and all became very panic. However, Cao Cao himself felt very proud of his interesting idea and enjoyed it.
Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army. Cao Cao got very angry at his cleverness and would like to punish Xiu Yang. But how can you punish someone because he's clever? By looking at the chicken rib, he finally got a new idea to punish Xiu Yang.
He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only use one stick as the container.
Formally, we can treat the container stick as an L length segment. And the gold sticks as segments too. There were many gold sticks with different length ai and value vi . Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. Luckily, Xiu Yang came up with a good idea. On the two sides of the container, he could make part of the gold sticks outside the container as long as the center of the gravity of each gold stick was still within the container. This could help him get more valuable gold sticks.
As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So no one knows how many gold sticks Xiu Yang made it in the container.
Can you help solve the mystery by finding out what's the maximum value of the gold sticks Xiu Yang could have taken?
Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army. Cao Cao got very angry at his cleverness and would like to punish Xiu Yang. But how can you punish someone because he's clever? By looking at the chicken rib, he finally got a new idea to punish Xiu Yang.
He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only use one stick as the container.
Formally, we can treat the container stick as an L length segment. And the gold sticks as segments too. There were many gold sticks with different length ai and value vi . Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. Luckily, Xiu Yang came up with a good idea. On the two sides of the container, he could make part of the gold sticks outside the container as long as the center of the gravity of each gold stick was still within the container. This could help him get more valuable gold sticks.
As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So no one knows how many gold sticks Xiu Yang made it in the container.
Can you help solve the mystery by finding out what's the maximum value of the gold sticks Xiu Yang could have taken?
Input
The first line of the input gives the number of test cases,
T(1≤T≤100)
.
T
test cases follow. Each test case start with two integers,
N(1≤N≤1000)
and
L(1≤L≤2000)
, represents the number of gold sticks and the length of the container stick.
N
lines follow. Each line consist of two integers,
ai(1≤ai≤2000)
and
vi(1≤vi≤109)
, represents the length and the value of the
ith
gold stick.
Output
For each test case, output one line containing
Case #x: y, where
x
is the test case number (starting from 1) and
y
is the maximum value of the gold sticks Xiu Yang could have taken.
Sample Input
4 3 7 4 1 2 1 8 1 3 7 4 2 2 1 8 4 3 5 4 1 2 2 8 9 1 1 10 3
Sample Output
Case #1: 2 Case #2: 6 Case #3: 11 Case #4: 3HintIn the third case, assume the container is lay on x-axis from 0 to 5. Xiu Yang could put the second gold stick center at 0 and put the third gold stick center at 5, so none of them will drop and he can get total 2+9=11 value. In the fourth case, Xiu Yang could just put the only gold stick center on any position of [0,1], and he can get the value of 3.
mark一下几个重要的思考点。
首先很能想到这是一个类似得背包问题。但是问题在于有的木棍可能伸出去,而且伸出去得长度根据木棍得长度不同而不同。那么就造成了背包得容量不定。
怎么解决呢?
要限制,那么就要多开一维。
dp[i][j][k],表示放置前i个棍子,容量为j,其中k个木棍放在边缘。
那么,我们到底把哪个棍子放在边缘?
用贪心的思想,在已经放上去的棍子中,我肯定会选择最长得那根放在边缘的位置。
这样递推式就出来了。只需要先对所有得棍子进行一个排序即可。
#include <cmath>
#include <cstring>
#include <cstdio>
#include <vector>
#include <string>
#include <algorithm>
#include <string>
#include <map>
#include <queue>
#include <set>
#include <stack>
#include <ctime>
#include <cstdlib>
#include <iostream>
#define pi 3.1415926
using namespace std;
const int MAXN = 4010;
long long dp[MAXN][3];
struct node{
int v,l;
};
node a[MAXN];
int cmp(node x,node y){
return x.l>y.l;
}
int main()
{
int t;
scanf("%d",&t);
for(int cas=1;cas<=t;cas++){
int n,l;
memset(dp,0,sizeof(dp));
scanf("%d%d",&n,&l);
l*=2;
for(int i=0;i<n;i++){
scanf("%d%d",&a[i].l,&a[i].v);
a[i].l*=2;
}
if(n==1){
printf("Case #%d: %d\n",cas,a[0].v);
continue;
}
sort(a,a+n,cmp);
long long ans=0;
for(int i=0;i<n;i++){
for(int j=l;j>=a[i].l/2;j--){
for(int k=0;k<3;k++){
if(j>a[i].l)
dp[j][k]=max(dp[j][k],dp[j-a[i].l][k]+a[i].v);
if(k)
dp[j][k]=max(dp[j][k],dp[j-a[i].l/2][k-1]+a[i].v);
ans=max(ans,dp[j][k]);
}
}
}
printf("Case #%d: %lld\n",cas,ans);
}
}