Coins 多重背包

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4
 
题意是这样的,给你若干种金币,每种金币若干个,先给你一个数字,要求这些金币任意组合,使得总价值不多于这个数字。
显然这是一道背包类型的题目,属于多重背包;然而没有优化它是会超时的 ,故用二进制来处理它
代码:
#include<iostream>
using namespace std;
#define MAX(a,b) a>b?a:b
int N,M;
int dp[100005];
int w[105],c[105];
void ZeroOnePack(int w ,int weight )//01背包
{
	int i;
	for(i=M;i>=w;i--)
	{
		dp[i]=MAX(dp[i],dp[i-w]+weight);
	}
}
void CompletePack(int w,int weight)//完全背包
{
	int i;
	for(i=w;i<=M;i++)
		dp[i]=MAX(dp[i],dp[i-w]+weight);
}
void MultiplePack(int w,int weight,int count)//多重背包
{
	if(w*count>=M)//转化为完全背包
		CompletePack(w,weight);
	else//转化为01背包
	{
		int k=1;
		while(k<=count)//二进制优化
		{
			ZeroOnePack(k*w,k*weight);
			count-=k;
			k<<1;
		}
		ZeroOnePack(count*w,count*weight);
	}
}
int main()
{
	int i,ans;
	while(~scanf("%d%d",&N,&M),M+N)
	{
		ans=0;
		for(i=1;i<=M;i++)
			dp[i]=-100000000;
		dp[0]=0;
		for(i=1;i<=N;i++)
			scanf("%d",&w[i]);
		for(i=1;i<=N;i++)
			scanf("%d",&c[i]);
		for(i=1;i<=N;i++)
			MultiplePack(w[i],w[i],c[i]);
		for(i=1;i<=M;i++)
			if(dp[i]>0)
				ans++;
			printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值