POJ 2965 The Pilots Brothers' refrigerator(DFS)

The Pilots Brothers' refrigerator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20726 Accepted: 7973 Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

与POJ1753类似,把矩阵的状态转换成一个16位的二进制数,'+'对应位为1,反之为0。到达终点的标志就是矩阵的二进制数为0。对4*4矩阵的16个点进行dfs,分为翻转和不翻转两种选择,最终输出路径。


#pragma commment(linker,"/STACK: 102400000 102400000")
#include<stack>
#include<queue>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN=1e5+50;
#define MAXI 0x3f3f3f

int step[20],ans;
stack<int>s;

int cmp(int a,int b)
{
    return a>b;
}

int change(int num,int n)
{
    int r=n/4,c=n%4;
    for(int i=0;i<16;i++)
        if(i/4==r||i%4==c)
            num^=(1<<(i));
    return num;
}

void dfs(int loc,int now,int num)
{
    if(now==0)
    {
        if(num<ans)
        {
            ans=num;
            int c=0;
            while(!s.empty())
            {
                int t=s.top();
                s.pop();
                step[c++]=t;
            }
            for(int i=c-1;i>=0;i--)
                s.push(step[i]);
        }
        return ;
    }
    if(loc<0)
        return ;
    s.push(loc);
    dfs(loc-1,change(now,loc),num+1);
    s.pop();
    dfs(loc-1,now,num);
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
#endif // ONLINE_JUDGE
    int s=0;
    char t;
    for(int i=0;i<4;i++)
    {
        for(int j=0;j<4;j++)
        {
            scanf("%c",&t);
            if(t=='+')
                s=s*2+1;
            else
                s=s*2+0;
        }
        getchar();
    }
    ans=20;
    dfs(15,s,0);
    printf("%d\n",ans);
    sort(step,step+ans,cmp);
    for(int i=0;i<ans;i++)
        printf("%d %d\n",(15-step[i])/4+1,(15-step[i])%4+1);
    return 0;
}

POJ 1321 排兵布阵问题可以使用 DFS 算法求解。 题目要求在一个 n x n 的棋盘上,放置 k 个棋子,其中每行、每列都最多只能有一个棋子。我们可以使用 DFS 枚举每个棋子的位置,对于每个棋子,尝试将其放置在每一行中未被占用的位置上,直到放置了 k 个棋子。在 DFS 的过程中,需要记录每行和每列是否已经有棋子,以便在尝试放置下一个棋子时进行判断。 以下是基本的 DFS 模板代码: ```python def dfs(row, cnt): global ans if cnt == k: ans += 1 return for i in range(row, n): for j in range(n): if row_used[i] or col_used[j] or board[i][j] == '.': continue row_used[i] = col_used[j] = True dfs(i + 1, cnt + 1) row_used[i] = col_used[j] = False n, k = map(int, input().split()) board = [input() for _ in range(n)] row_used = [False] * n col_used = [False] * n ans = 0 dfs(0, 0) print(ans) ``` 其中,row 代表当前尝试放置棋子的行数,cnt 代表已经放置的棋子数量。row_used 和 col_used 分别表示每行和每列是否已经有棋子,board 则表示棋盘的状态。在尝试放置棋子时,需要排除掉无法放置的位置,即已经有棋子的行和列,以及棋盘上标记为 '.' 的位置。当放置了 k 个棋子时,即可计数一次方案数。注意,在回溯时需要将之前标记为已使用的行和列重新标记为未使用。 需要注意的是,在 Python 中,递归深度的默认限制为 1000,可能无法通过本题。可以通过以下代码来解除限制: ```python import sys sys.setrecursionlimit(100000) ``` 完整代码如下:
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值