POJ 1315 Don't Get Rooked(DFS)

Don't Get Rooked
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2290 Accepted: 1463

Description

In chess, the rook is a piece that can move any number of squares vertically or horizontally. In this problem we will consider small chess boards (at most 4x4) that can also contain walls through which rooks cannot move. The goal is to place as many rooks on a board as possible so that no two can capture each other. A configuration of rooks is legal provided that no two rooks are on the same horizontal row or vertical column unless there is at least one wall separating them. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of rooks in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 

Your task is to write a program that, given a description of a board, calculates the maximum number of rooks that can be placed on the board in a legal configuration. 

Input

The input contains one or more board descriptions, followed by a line containing the number 0 that signals the end of the file. Each board description begins with a line containing a positive integer n that is the size of the board; n will be at most 4. The next n lines each describe one row of the board, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input.

Output

For each test case, output one line containing the maximum number of rooks that can be placed on the board in a legal configuration.

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output

5
1
5
2
4

和N皇后问题类似,这道题让求出棋盘在被墙分隔的情况下的最多能放的棋子的个数,使分隔后的每行每列仅有一个棋子。方法是从前到后dfs,同时用4个循环判断位置是否合法。


#include<queue>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN=1e2+50;

char map[MAXN][MAXN];
int vis[MAXN][MAXN],N,ans;

int over(int x,int y)
{
    if(x<0||x>=N||y<0||y>=N)
        return 1;
    return 0;
}

int judge(int x,int y)
{
    for(int i=x-1; i>=0&&map[i][y]=='.'; i--)
    {
        if(vis[i][y])
        {
            return 0;
        }
    }
    for(int i=x+1; i<N&&map[i][y]=='.'; i++)
    {
        if(vis[i][y])
        {
            return 0;
        }
    }
    for(int i=y-1; i>=0&&map[x][i]=='.'; i--)
    {
        if(vis[x][i])
        {
            return 0;
        }
    }
    for(int i=y+1; i<N&&map[x][i]=='.'; i++)
    {
        if(vis[x][i])
        {
            return 0;
        }
    }
    return 1;
}

void dfs(int x,int y,int num)
{
    if(over(x,y))
        return ;
    ans=max(ans,num);
    for(int i=x*N+y+1; i<N*N; i++)
    {
        int xx=i/N;
        int yy=i%N;
        if(!vis[xx][yy]&&!over(xx,yy)&&map[xx][yy]=='.'&&judge(xx,yy))
        {
            vis[xx][yy]=1;
            dfs(xx,yy,num+1);
            vis[xx][yy]=0;
        }
    }
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
#endif // ONLINE_JUDGE
    while(scanf("%d%*c",&N)!=EOF&&N)
    {
        ans=0;
        for(int i=0; i<N; i++)
        {
            for(int j=0; j<N; j++)
            {
                scanf("%c",&map[i][j]);
            }
            getchar();
        }
        memset(vis,0,sizeof(vis));
        for(int i=0; i<N*N; i++)
        {
            int x=i/N,y=i%N;
            if(map[x][y]=='.')
            {
                vis[x][y]=1;
                dfs(x,y,1);
                vis[x][y]=0;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值