POJ 3268 Silver Cow Party(dijkstra+矩阵转置)

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 15460 Accepted: 7004

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题目大意:

n头牛要到达某一个点X,然后再返回到原来的位置。同时要求对于每头牛路径必须是最短的,而且去的路和回来的路不一样。求这些牛所花费的最长时间。

解题思路:
首先返回的路很好求,以X为起点求到达各个点的最短路。然后我们只需要求出到达X的最短路。
在别人那里知道了矩阵转置这个东西,其实要求到达X的最短路,我们只需要把每个边权值不变,方向调转,那么我们再按照求从X出发的单源最短路的方法,就可以求出到达X的最短路了。最后循环一遍求出到达和返回的和的最大值。


参考代码:

#include<stack>
#include<queue>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const double eps=1e-10;
const int INF=0x3f3f3f3f;
const int MAXN=1100;

int n,m,p,edge[MAXN][MAXN],backedge[MAXN][MAXN],mincost1[MAXN],mincost2[MAXN];
bool used1[MAXN],used2[MAXN];

void dijkstra(int start)
{
    for(int i=1; i<=n; i++)
    {
        used1[i]=used2[i]=false;
        mincost1[i]=edge[start][i];
        mincost2[i]=edge[i][start];
    }
    used1[start]=used2[start]=true;
    int v;
    while(true)
    {
        v=-1;
        for(int i=1; i<=n; i++)
            if(!used1[i]&&(v==-1||mincost1[i]<mincost1[v]))
                v=i;
        if(v==-1)
            break;
        used1[v]=true;
        for(int i=1; i<=n; i++)
            if(!used1[i]&&mincost1[i]>mincost1[v]+edge[v][i])
                mincost1[i]=mincost1[v]+edge[v][i];

        v=-1;
        for(int i=1; i<=n; i++)
            if(!used2[i]&&(v==-1||mincost2[i]<mincost2[v]))
                v=i;
        if(v==-1)
            break;
        used2[v]=true;
        for(int i=1; i<=n; i++)
            if(!used2[i]&&mincost2[i]>mincost2[v]+backedge[v][i])
                mincost2[i]=mincost2[v]+backedge[v][i];
    }
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
#endif // ONLINE_JUDGE
    while(scanf("%d%d%d",&n,&m,&p)!=EOF)
    {
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                if(i==j)
                    edge[i][j]=backedge[i][j]=0;//方向相反
                else
                    edge[i][j]=backedge[i][j]=INF;
        for(int i=1; i<=m; i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            edge[b][a]=backedge[a][b]=c;
        }
        dijkstra(p);
        int ans=-1;
        for(int i=1; i<=n; i++)
            ans=max(ans,mincost1[i]+mincost2[i]);
        printf("%d\n",ans);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是Java解决POJ3233—矩阵幂序列问题的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘法 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速幂 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加法 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k次幂矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘法,matrixPow函数实现矩阵快速幂,matrixAdd函数实现矩阵加法,printMatrix函数实现输出矩阵
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值