POJ 2104-K-th Number-主席树模板

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1…n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: “What would be the k-th number in a[i…j] segment, if this segment was sorted?”
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2…5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n — the size of the array, and m — the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values — the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it — the k-th number in sorted a[i…j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

题目大意:

给定一个n元素数组。
有m次查询,每次查询给定一个区间[ l , r ],求区间第k小元素的值。

核心思想:

主席树模板题。

代码如下:

#include<cstdio>
#include<iostream>
#include<algorithm> 
using namespace std;
typedef long long ll;
const int N=1e5+20;
int b[N],cb,ct,root[N];
struct Node{
	int x,id;
}a[N];
struct node{
	int l,r,sum;
}tr[N<<5];
//l,r是数值范围,v是数值大小,pre是上一个版本的参照结点编号,now是当前结点编号 
void insert(int l,int r,int pre,int &now,int v)
{
	tr[++ct]=tr[pre];
	now=ct;
	tr[now].sum++;
	if(l==r)
		return;
	int mid=(l+r)>>1;
	if(v<=mid)
		insert(l,mid,tr[pre].l,tr[now].l,v);
	else
		insert(mid+1,r,tr[pre].r,tr[now].r,v);
	return;
}
//l,r是数值范围,L,R是位置区间(也代表主席树版本),k是个数要求(区间第k小) 
int query(int l,int r,int L,int R,int k)
{
	if(l==r)
		return l;
	int mid=(l+r)>>1;
	int t=tr[tr[R].l].sum-tr[tr[L].l].sum;
	if(k<=t)
		return query(l,mid,tr[L].l,tr[R].l,k);
	return query(mid+1,r,tr[L].r,tr[R].r,k-t);
}
int getid(int x)
{
	return lower_bound(b,b+cb,x)-b+1;
}
bool cmp1(Node p,Node q)
{
	return p.x<q.x;
}
bool cmp2(Node p,Node q)
{
	return p.id<q.id;
}
int main()
{
	int n,m,x,y,k;
	while(~scanf("%d%d",&n,&m))
	{
		cb=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i].x);
			a[i].id=i;
		}
		//离散化
		a[0].x=-1e9-1;
		sort(a+1,a+n+1,cmp1);
		for(int i=1;i<=n;i++)
			if(a[i].x!=a[i-1].x)
				b[cb++]=a[i].x;
		sort(a+1,a+n+1,cmp2);
		//建主席树 
		ct=0;
		tr[0].l=tr[0].r=tr[0].sum=0;
		for(int i=1;i<=n;i++)
			insert(1,n,root[i-1],root[i],getid(a[i].x));
		//查询 
		for(int i=0;i<m;i++)
		{
			scanf("%d%d%d",&x,&y,&k);
			printf("%d\n",b[query(1,n,root[x-1],root[y],k)-1]);
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值