CF1288B-Yet Another Meme Problem

Description

Try guessing the statement from this picture http://tiny.cc/ogyoiz.

You are given two integers A and B, calculate the number of pairs (a,b) such that 1≤a≤A, 1≤b≤B, and the equation a⋅b+a+b=conc(a,b) is true; conc(a,b) is the concatenation of a and b (for example, conc(12,23)=1223, conc(100,11)=10011). a and b should not contain leading zeroes.

Input

The first line contains t (1≤t≤100) — the number of test cases.

Each test case contains two integers A and B (1≤A,B≤109).

Output

Print one integer — the number of pairs (a,b) such that 1≤a≤A, 1≤b≤B, and the equation a⋅b+a+b=conc(a,b) is true.

Sample Input

3
1 11
4 2
191 31415926

Sample Output

1
0
1337

核心思想:

a⋅b+a+b=conc(a,b)
==>a·b+a=a*10w(上式两侧同减b,w为b的位数)
==>b+1=10w(上式两侧同除a)
由上式可以看出,b为10w-1,例如9,99,999,9999……
a无限制条件。

代码如下:

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
int main()
{
	int T;
	ll a,b;
	cin>>T;
	while(T--)
	{
		scanf("%lld%lld",&a,&b);
		ll sum=0,t=9;
		while(t<=b)
		{
			sum++;
			t=t*10+9; 
		}
		printf("%lld\n",a*sum);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值