HDU 4597-Play Game-记忆化搜索

Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?

Input

The first line contains an integer T (T≤100), indicating the number of cases.
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer ai (1≤ai≤10000). The third line contains N integer bi (1≤bi≤10000).

Output

For each case, output an integer, indicating the most score Alice can get.

Sample Input

2

1
23
53

3
10 100 20
2 4 3

Sample Output

53 
105 

题目大意:

有两个数组,两人轮流取数直到取完。每次只允许取一个,只能从某个数组的最左侧或最右侧取。

核心思想:

记忆化搜索。
dp[l1][r1][l2][r2]表示面对第一个数组剩下l1到r1位置的元素且第二个数组剩下l2到r2位置的元素时,可以比另外一个人多获得的分数。
设总分为sum,A比B多获得re分,则
A+B=sum
A-B=re
则A=(sum+re)/2。
详见代码。

代码如下:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int N=23;
int dp[N][N][N][N],a[N],b[N];
int dfs(int l1,int r1,int l2,int r2)
{
	if(dp[l1][r1][l2][r2]!=-inf)
		return dp[l1][r1][l2][r2];
	if(l1>r1&&l2>r2)
		return dp[l1][r1][l2][r2]=0;
	int ans=-inf;
	//从第一个数组取 
	if(l1<=r1)
	{
		ans=max(ans,a[l1]-dfs(l1+1,r1,l2,r2));//左侧取 
		ans=max(ans,a[r1]-dfs(l1,r1-1,l2,r2));//右侧取 
	}
	//从第二个数组取 
	if(l2<=r2)
	{
		ans=max(ans,b[l2]-dfs(l1,r1,l2+1,r2));//左侧取 
		ans=max(ans,b[r2]-dfs(l1,r1,l2,r2-1));//右侧取 
	}
	//记忆并返回最大值 
	return dp[l1][r1][l2][r2]=ans;
}
int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		int n,sum=0;
		scanf("%d",&n);
		//初始化 
		for(int i=0;i<N;i++)
			for(int j=0;j<N;j++)
				for(int z=0;z<N;z++)
					for(int k=0;k<N;k++)
						dp[i][j][z][k]=-inf;
		//输入 
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			sum+=a[i];
		}
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&b[i]);
			sum+=b[i];
		}
		//搜索 
		int re=dfs(1,n,1,n);
		//输出 
		printf("%d\n",(sum+re)>>1);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值