ZOJ 2972-Hurdles of 110m-记忆化搜索

Description

In the year 2008, the 29th Olympic Games will be held in Beijing. This will signify the prosperity of China and Beijing Olympics is to be a festival for people all over the world as well.

Liu Xiang is one of the famous Olympic athletes in China. In 2002 Liu broke Renaldo Nehemiah’s 24-year-old world junior record for the 110m hurdles. At the 2004 Athens Olympics Games, he won the gold medal in the end. Although he was not considered as a favorite for the gold, in the final, Liu’s technique was nearly perfect as he barely touched the sixth hurdle and cleared all of the others cleanly. He powered to a victory of almost three meters. In doing so, he tied the 11-year-old world record of 12.91 seconds. Liu was the first Chinese man to win an Olympic gold medal in track and field. Only 21 years old at the time of his victory, Liu vowed to defend his title when the Olympics come to Beijing in 2008.
在这里插入图片描述 In the 110m hurdle competition, the track was divided into N parts by the hurdle. In each part, the player has to run in the same speed; otherwise he may hit the hurdle. In fact, there are 3 modes to choose in each part for an athlete – Fast Mode, Normal Mode and Slow Mode. Fast Mode costs the player T1 time to pass the part. However, he cannot always use this mode in all parts, because he needs to consume F1 force at the same time. If he doesn’t have enough force, he cannot run in the part at the Fast Mode. Normal Mode costs the player T2 time for the part. And at this mode, the player’s force will remain unchanged. Slow Mode costs the player T3 time to pass the part. Meanwhile, the player will earn F2 force as compensation. The maximal force of a player is M. If he already has M force, he cannot earn any more force. At the beginning of the competition, the player has the maximal force.

The input of this problem is detail data for Liu Xiang. Your task is to help him to choose proper mode in each part to finish the competition in the shortest time.

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 50) which is the number of test cases. And it will be followed by T consecutive test cases.

Each test case begins with two positive integers N and M. And following N lines denote the data for the N parts. Each line has five positive integers T1 T2 T3 F1 F2. All the integers in this problem are less than or equal to 110.

Output

Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the shortest time that Liu Xiang can finish the competition.

Sample Input

2
1 10
1 2 3 10 10
4 10
1 2 3 10 10
1 10 10 10 10
1 1 2 10 10
1 10 10 10 10

Sample Output

1
6

题目大意:

给定n个部分,刘翔在每个部分有三种奔跑模式:
1、快速模式,花费时间T1,耗费力量F1。
2、中速模式,花费时间T2,力量值不变。
3、慢速模式,花费时间T3,恢复力量F2。
刘翔力量上限为m。
开始的时候刘翔的力量是满的m。
问刘翔如何制定奔跑策略,可以使总时间最短。

核心思想:

记忆化搜索。
dp[i][j]表示当刘翔即将开始第 i 段且现有力量 j 时,跑余下的路程需要的时间。
三种模式向后搜索,取最短时间。
详见代码。

代码如下:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int N=150;
int n,m,mx=inf,dp[N][N];
struct node{
	int t1,t2,t3,f1,f2;
}h[N];
//即将开始第k段,现有力量值为y 
int dfs(int k,int y)
{
	if(dp[k][y]!=-1)
		return dp[k][y];
	if(k>n)
		return 0;
	int ans=inf;
	//快速模式 
	if(y>=h[k].f1)
		ans=min(ans,h[k].t1+dfs(k+1,y-h[k].f1));
	//中速模式 
	ans=min(ans,h[k].t2+dfs(k+1,y));
	//慢速模式 
	ans=min(ans,h[k].t3+dfs(k+1,min(y+h[k].f2,m)));//注意上限
	//记忆并返回最小值 
	return dp[k][y]=ans;
}
int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		memset(dp,-1,sizeof(dp));
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
			scanf("%d%d%d%d%d",&h[i].t1,&h[i].t2,&h[i].t3,&h[i].f1,&h[i].f2);
		printf("%d\n",dfs(1,m));
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值