POJ 3279 Fliptile

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input
Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output
Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output
  
  
0 0 0 0 1 0 0 1 1 0 0 1 0 0 0 0

题目大意:

给你一张 N x M的只存在01的地图, 需要用字典序最小的步数将整张地图翻为全0, 如果不行则输出IMPOSSIBLE。翻1的规则为包括自身在内的上下左右全部翻转(1变0 0变1).

解题思路:

首先看题目数据量, 如果单纯枚举每个点翻或不翻的情况必定超时, 所以我们换一种思路, 对于每一行, 它的结果只会因他的上一层数字而影响, 所以我们可以枚举第一排的所有点, 对于剩下的行我们只要逐行枚举它的上一行是否为1, 如果为1就翻当前这个点, 这样到最后一行时, 如果他能翻为全0地图的话, 最后一行必定是全0的, 否则就说明上一行有没翻为0的或是最后一行本身包含1,对于答案的保存, 我们因为要找字典序最小的, 就设一个临时变量去计当前状态所需要的步数, 取最小值,最后输出地图即可。

代码:

#include <iostream>
#include <sstream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iomanip>
#include <utility>
#include <string>
#include <cmath>
#include <vector>
#include <bitset>
#include <stack>
#include <queue>
#include <deque>
#include <map>
#include <set>

using namespace std;

/*
 *ios::sync_with_stdio(false);
 */

typedef long long ll;
typedef unsigned long long ull;
const int dir[5][2] = {0, 1, 0, -1, 1, 0, -1, 0, 0, 0};
const int inf = 0x7fffffff;
const int mod = 1000000;
const int Max = 17;

int n, m, ans;
int Map[Max][Max], cur[Max][Max], res[Max][Max], temp[Max][Max];

bool ok(int i, int j) {
    if (i > 0 && i <= n && j > 0 && j <= m)
        return true;
    return false;
}

bool check() {
    for (int i = 1; i <= m; ++i)
        if (cur[n][i])
            return false;
    return true;
}

void flip(int x, int y) {
    temp[x][y] = 1;
    int tempx, tempy;
    for (int i = 0; i < 5; ++i) {
        tempx = x + dir[i][0];
        tempy = y + dir[i][1];
        if (ok(tempx, tempy))
            cur[tempx][tempy] = !cur[tempx][tempy];
    }
}

void enume(int x) {
    // flip times
    int cnt = 0;
    memcpy(cur, Map, sizeof(Map));
    memset(temp, 0, sizeof(temp));
    for (int i = 0; i < m; ++i) {
        // (x / i) + 1
        if ((x >> i) & 1) {
            flip(1, i + 1);
            cnt++;
        }
    }
    for (int i = 2; i <= n; ++i) {
        for (int j = 1; j <= m; ++j) {
            // upon position
            if (cur[i - 1][j] == 1) {
                flip(i, j);
                cnt++;
            }
        }
    }
    //printf("%d %d\n", cnt, ans);
    if (check() && (cnt < ans)) {
        ans = cnt;
        memcpy(res, temp, sizeof(temp));
    }
}

int main() {
    // initialization
    scanf("%d %d", &n, &m);
    for (int i = 1; i <= n; ++i) {
        for (int j = 1; j <= m; ++j) {
            scanf("%d", &Map[i][j]);
        }
    }
    // perform the algorithm
    ans = inf;
    // enumerate first row's status
    for (int i = 0; i < (1 << m); ++i) enume(i);
    if (ans == inf)
        printf("IMPOSSIBLE\n");
    else
        for (int i = 1; i <= n; ++i)
            for (int j = 1; j <= m; ++j)
                printf("%d%c", res[i][j], j == m ? '\n' : ' ');
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值