POJ 3279 Fliptile(状压DP)

Fliptile
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13008 Accepted: 4768

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

思路:

看了半天题目才发现是以前无聊时玩过的关灯游戏(英语渣非常痛苦ORZ)。

对于每个位置按奇数次和1次等价,按偶数次和0次等价,所以最优情况下,各点点击次数只存在0和1。

穷尽是2^(15*15)应该会超时,可以穷举第一行2^15种情况。

根据第一行的点击情况可以递推出最后一行(从第二行开始由上至下  每点都判断  该点击位置  的  上面那一个位置  是否为1,是则该点击位置也为1)。

如果最后一行全为0,即该方案可行。

代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<queue>
using namespace std;
#define mod 1000000007
#define ll long long
#define INF 0x3f3f3f3f

//start存储灯初始状态,TS存储各个位置点击次数,ans存储答案
int start[20][20],TS[20][20],ans[20][20];
int row,column;

int main(){
//避免越界,和各个数组之间存储是从0还是1开始混淆,统一从(1,1)开始存储
    scanf("%d%d",&row,&column);
    int i,j,k,cnt,flag,minn=INF;
    for(i=1;i<=row;i++)
        for(j=1;j<=column;j++)
            scanf("%d",&start[i][j]);
    int uli=1<<column;
    for(i=0;i<uli;i++){
        cnt=0;  //初始化该情况的点击次数
        
        //枚举子集
        for(j=0;j<column;j++){
            if(1<<j&i){
                TS[1][column-j]=1;
                cnt++;
            }
            else
                TS[1][column-j]=0;
        }

//        for(int i=1;i<=1;i++){
//            for(int j=1;j<column;j++)
//                printf("%d ",TS[i][j]);
//            printf("%d\n\n",TS[i][j]);
//        }

//从上至下递得到各个位置应点击次数
        for(j=2;j<=row;j++){
            for(k=1;k<=column;k++){
//根据上面一格位置的状态,判断该位置是否需要点击
                if((start[j-1][k]+TS[j-2][k]+TS[j-1][k-1]+TS[j-1][k+1]+TS[j-1][k])&1){
                    TS[j][k]=1;
                    cnt++;
                }
                else
                    TS[j][k]=0;
            }
        }

        if(cnt>=minn)continue;//判断当前情况点击次数是否大于最小次数,是则判断下种情况

//判断该点击方法是否正确
        flag=1;
        for(j=1;j<=column;j++){
            if((start[row][j]+TS[row][j-1]+TS[row][j+1]+TS[row-1][j]+TS[row][j])&1){
                flag=0;
                break;
            }
        }

        //如果正确,且是当前最小方案,存储到ans
        if(flag){
            minn=cnt;
            for(j=1;j<=row;j++)
                for(k=1;k<=column;k++)
                    ans[j][k]=TS[j][k];
        }
    }

//如果不存在则minn==INF
    if(minn==INF)printf("IMPOSSIBLE\n");
    else {
        for(i=1;i<=row;i++){
            for(j=1;j<column;j++)
                printf("%d ",ans[i][j]);
            printf("%d\n",ans[i][j]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值