Buy Sticks


Problem Description
Imyourgod need 3 kinds of sticks which have different sizes: 20cm, 28cm and 32cm. However the shop only sell 75-centimeter-long sticks. So he have to cut off the long stick. How many sticks he must buy at least.

Input
The first line of input contains a number t, which means there are t cases of the test data.
There will be several test cases in the problem, each in one line. Each test cases are described by 3 non-negtive-integers separated by one space representing the number of sticks of 20cm, 28cm and 32cm. All numbers are less than 10^6.

Output
The output contains one line for each line in the input case. This line contains the minimal number of 75-centimeter-long sticks he must buy. Format are shown as Sample Output.

Sample Input
  
  
2 3 1 1 4 2 2

Sample Output
  
  
Case 1: 2 Case 2: 3

Author
imyourgod (Special Thanks : crackerwang & Louty)

Source

题解:可以将28,32看成一种stick,即有三种分发:1)20+20+20,2)20+20+28,20+20+32,3)28+28,28+32,32+32.

先选择第二种分发,若n(20)>=2*n(28+132)选择第一种分法,否则选择第三种分法。

#include<iostream>
#include<stdio.h>
using namespace std;
int t;
int main(){
    scanf("%d",&t);
    for(int tt=1;tt<=t;tt++){
        int a,b,c,ans=0;
        scanf("%d%d%d",&a,&b,&c);
        b+=c;
        if(a>=b*2){
            ans+=b;
            a-=b*2;
            ans+=a/3+(a%3!=0);
        }
        else{
            ans+=a/2+a%2;
            b-=a/2+a%2;
            ans+=b/2+b%2;
        }
        printf("Case %d: %d\n",tt,ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值