1007 Maximum Subsequence Sum (25分)

题目
Given a sequence of K integers { N​1​​, N​2​​, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

一开始看到题目是最大子列和问题,就想到了在MOOC上面看数据结构时何老师讲的动态规划的做法。

#include<iostream>
using namespace std;
const int maxn = 1e4 + 5;
int a[maxn];
int main() {
	int n;
	cin >> n;
	int tempsum = 0, maxsum = -1;	//分别记录临时子列和,最大子列和
	int tempstart = 0, start = 0, end = n - 1;	//子列的最左端和最右端
	for (int i = 0; i < n; i++) {
		scanf("%d", &a[i]);
		tempsum += a[i];
		if (tempsum < 0) {	//当前子列和小于0,则舍弃,同时更新左端点
			tempstart = i + 1;
			tempsum = 0;
		}
		else if (tempsum > maxsum) {//更新最大和
			maxsum = tempsum;
			end = i;	//更新右节点
			start = tempstart;
		}
	}
	if (maxsum < 0) maxsum = 0;
	printf("%d %d %d", maxsum, a[start], a[end]);
	return 0;
}

接触到动态DP的第一道题,当做例题给记录下来。左端点要设两个变量来储存,只有当最大值需要更新时,真正的左端点才被临时记录的左端点所赋值。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值