1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N
​1
​​ , N
​2
​​ , …, N
​K
​​ }. A continuous subsequence is defined to be { N
​i
​​ , N
​i+1
​​ , …, N
​j
​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

题意

给你k个数字输出他的最大子段和以及字段和的开始元素结束元素,若最大字段和是负的,则输出数组的第一个元素和最后一个元素,若最大字段和不唯一那么输出开始下标最小的那一组

思路

直接上dp,可以得到转移方程 d p [ i ] = m a x ( a [ i ] , d p [ i − 1 ] + a [ i ] ) dp[i]=max(a[i],dp[i-1]+a[i]) dp[i]=max(a[i],dp[i1]+a[i])
其实意思也好理解,判断当前是取和还是取单个元素哪一个较大。
dp只能记录子段和的值但是无法记录开始值和结束值,但是我们可以在得到最大的 m a x n = d p [ i ] maxn=dp[i] maxn=dp[i]后再遍历一次(从头开始遍历)dp数组,当dp[i]等于maxn的时候就跳出,那我们可以得到结束值得下标。然后再从结束值下标从后往前再遍历一遍数组,这次遍历的时候顺便求个和,若和等于maxn则就找到了一组解,但是不能直接跳出,因为这个解可能不是开始下标最小的值。所以一直遍历到数组头即可,复杂度还是 O ( n ) O(n) O(n)

#include <bits/stdc++.h>
using namespace std;
int dp[10005];
int a[10005];
int main()
{
    int n;
    scanf("%d",&n);
    int maxn=0;
    int l=0;
    int r=0;
    for(int i=0; i<n; i++)
    {
        scanf("%d",&a[i]);
        if(!i)
        {
            dp[i]=a[i];
            maxn=dp[i];
        }
        else
        {
            dp[i]=max(a[i],dp[i-1]+a[i]);
            maxn=max(maxn,dp[i]);
        }
    }
    for(int i=0; i<n; i++)
    {
        if(dp[i]==maxn)
        {
            r=i;
            break;
        }
    }
    int sum=0;
    for(int i=r; i>=0; i--)
    {
        sum+=a[i];
        if(sum==maxn)
            l=i;
    }
    if(maxn<0)
        printf("%d %d %d\n",0,a[0],a[n-1]);
    else
        printf("%d %d %d\n",maxn,a[l],a[r]);
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值