VPN(虚拟专用网络)

 首先进行IP地址的规划:

R1    S4/0/0    15.1.1.1/24                 G0/0/0    192.168.1.1/24
R2    S4/0/0    25.1.1.2/24                 G0/0/0    192.168.2.1/24
R3    S4/0/0    35.1.1.3/24                 G0/0/0    192.168.3.1/24
R4    S4/0/0    45.1.1.4/24                 G0/0/0    192.168.4.1/24
R5    S4/0/0    15.1.1.5/24   
         S4/0/1    25.1.1.5/24 
         S3/0/0    35.1.1.5/24   
         G0/0/0    45.1.1.5/24         
         loopback0   5.5.5.5/24
PC1      192.168.1.2/24
PC2      192.168.2.2/24
PC3      192.168.3.2/24
PC4      192.168.4.2/24
规划好IP地址之后,对其相应设备进行配置:
R1:
[R1]interface g0/0/0
[R1-GigabitEthernet0/0/0]ip address 192.168.1.1 24
[R1]interface s4/0/0
[R1-Serial4/0/0]ip address 15.1.1.1 24
R2:
[R2]interface g0/0/0
[R2-GigabitEthernet0/0/0]ip address 192.168.2.1 24
[R2]interface s4/0/0
[R2-Serial4/0/0]ip address 25.1.1.2 24
R3:
[R3]interface g0/0/0
[R3-GigabitEthernet0/0/0]ip address 192.168.3.1 24
[R3]interface s4/0/0
[R3-Serial4/0/0]ip address 35.1.1.3 24
R4:
[R4]interface g0/0/0
[R4-GigabitEthernet0/0/0]ip address 45.1.1.4 24
[R4]interface g0/0/1
[R4-GigabitEthernet0/0/1]ip address 192.168.4.1 24
R5:
interface Serial3/0/0
ip address 35.1.1.5 255.255.255.0
interface Serial4/0/0
ip address 15.1.1.5 255.255.255.0
interface Serial4/0/1
ip address 25.1.1.5 255.255.255.0
interface GigabitEthernet0/0/0
ip address 45.1.1.5 255.255.255.0
将所有IP地址下发之后,器配置却省路由,使其全网可达:
[R1]ip route-static 0.0.0.0 0 15.1.1.5
[R2]ip route-static 0.0.0.0 0 25.1.1.5
[R3]ip route-static 0.0.0.0 0 35.1.1.5
[R4]ip route-static 0.0.0.0 0 45.1.1.5
因为R5与R1-R4分别都是直连,所以R1-R4的下一跳所指向的都是R5的接口。随后对R1-R3配置NAT:
R1:
[R1]acl 2000
[R1-acl-basic-2000]rule 1 permit source any
[R1-acl-basic-2000]q
[R1]inter s4/0/0
[R1-Serial4/0/0]nat outbound 2000
R2:
[R2]acl 2000
[R2-acl-basic-2000]rule 1 permit source any
[R2-acl-basic-2000]q
[R2]inter s4/0/0
[R2-Serial4/0/0]nat outbound 2000
R3:
[R3]acl 2000
[R3-acl-basic-2000]rule 1 permit source any
[R3-acl-basic-2000]q
[R3]inter s4/0/0
[R3-Serial4/0/0]nat outbound 2000
对R1和R5间使用PPP的PAP认证,R5为主认证方。
配置如下:
R5:主认证方配置
[R5]aaa
[R5-aaa]local-user huawei password cipher huawei
[R5-aaa]local-user huawei service-type ppp
[R5]interface s3/0/0
[R5-Serial3/0/0]ppp authentication-mode pap
R1:  被认证方配置
[R1]interface s4/0/0
[R1-Serial4/0/0]ppp pap local-user huawei password cipher huawei
对R2与R5间使用PPP的chap认证,R5为主认证方。
配置如下:
R5:    主认证方配置
[R5]aaa
[R5-aaa]local-user huawei password cipher huawei
[R5-aaa]local-user huawei service-type ppp
[R5]interface s3/0/1
[R5-Serial3/0/1]ppp authentication-mode chap
R2:  被认证方配置
[R2]interface s4/0/0
[R2-Serial4/0/0]ppp chap user huawei
[R2-Serial4/0/0]ppp chap password cipher huawei
对R3与R5之间使用HDLC封装。
R3:
[R3]inter s4/0/0
[R3-Serial4/0/0]link-protocol hdlc
R5:
[R5]interface s4/0/0
[R5-Serial4/0/0]link-protocol hdlc
R1/R2/R3构建一个MGRE环境,R1为中心站点;R1、R4间为点到点的GRE。
R1/R2/R3间MGRE配置如下:
R1:
[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]ip address 10.1.1.1 24
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp
[R1-Tunnel0/0/0]source 15.1.1.1
[R1-Tunnel0/0/0]nhrp network-id 100
R2:
[R2]interface Tunnel 0/0/0
[R2-Tunnel0/0/0]ip address 10.1.1.2 24
[R2-Tunnel0/0/0]tunnel-protocol gre p2mp
[R2-Tunnel0/0/0]source s4/0/0
[R2-Tunnel0/0/0]nhrp entry 10.1.1.1 15.1.1.1 register
[R2-Tunnel0/0/0]nhrp network-id 100
R3:
[R3]interface Tunnel 0/0/0
[R3-Tunnel0/0/0]ip address 10.1.1.3 24
[R3-Tunnel0/0/0]tunnel-protocol gre p2mp
[R3-Tunnel0/0/0]source s4/0/0
[R3-Tunnel0/0/0]nhrp network-id 100
[R3-Tunnel0/0/0]nhrp entry 10.1.1.1 15.1.1.1 register
R1/R4间GRE配置如下:
R1:
[R1]interface Tunnel 0/0/1
[R1-Tunnel0/0/1]ip address 20.1.1.1 24
[R1-Tunnel0/0/1]tunnel-protocol gre
[R1-Tunnel0/0/1]source 15.1.1.1
[R1-Tunnel0/0/1]destination 45.1.1.4
R4:
[R4]interface Tunnel 0/0/1
[R4-Tunnel0/0/1]ip address 20.1.1.2 24
[R4-Tunnel0/0/1]tunnel-protocol gre
[R4-Tunnel0/0/1]source 45.1.1.4
[R4-Tunnel0/0/1]destination 15.1.1.1
在MGRE环境下配置RIP:
R1:
[R1]rip 1
[R1-rip-1]version 2
[R1-rip-1]network 192.168.1.0
[R1-rip-1]network 10.0.0.0
[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]nhrp entry multicast dynamic              // 开启伪⼴播
[R1-Tunnel0/0/0]undo rip split-horizon                          // 关闭⽔平分割
R2:
[R2]rip 1
[R2-rip-1]version 2
[R2-rip-1]network 192.168.2.0
[R2-rip-1]network 10.0.0.0
R3:
[R3]rip 1
[R3-rip-1]version 2
[R3-rip-1]network 192.168.3.0
[R3-rip-1]network 10.0.0.0
在GRE环境下配置RIP:
R1:
[R1]rip 1
[R1-rip-1]version 2
[R1-rip-1]network 20.0.0.0
R4:
[R4]rip 1
[R4-rip-1]version 2
[R4-rip-1]network 20.0.0.0
[R4-rip-1]network 192.168.4.0
至此,实验结束。
  • 6
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值