1043 输出PATest (20分)
给定一个长度不超过 104 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest… 这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。
输入格式:
输入在一行中给出一个长度不超过 104 的、仅由英文字母构成的非空字符串。
输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例:
redlesPayBestPATTopTeePHPereatitAPPT
输出样例:
PATestPATestPTetPTePePee
样例解答:
import java.io.BufferedReader;
import java.io.InputStreamReader;
public class Main {
public static void main(String[] args) throws Exception{
BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
String s = bf.readLine();
bf.close();
int[] a = new int[6];
for(int i=0;i<s.length();i++) {
char ch = s.charAt(i);
if(ch=='P') a[0]++;
else if(ch=='A') a[1]++;
else if(ch=='T') a[2]++;
else if(ch=='e') a[3]++;
else if(ch=='s') a[4]++;
else if(ch=='t') a[5]++;
}
while(a[0]+a[1]+a[2]+a[3]+a[4]+a[5]!=0) {
if(a[0]!=0) {
System.out.print("P");
a[0]--;
}
if(a[1]!=0){
System.out.print("A");
a[1]--;
}
if(a[2]!=0){
System.out.print("T");
a[2]--;
}
if(a[3]!=0){
System.out.print("e");
a[3]--;
}
if(a[4]!=0){
System.out.print("s");
a[4]--;
}
if(a[5]!=0){
System.out.print("t");
a[5]--;
}
}
}
}