uva757

 


  Gone Fishing 

John is going on a fishing trip. He has h hours available ( $1 \leŸ h \leŸ 16$), and there aren lakes in the area ( $2 \leŸ n \leŸ 25$) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each$i = 1, \dots, n- 1$, the number of 5-minute intervals it takes to travel from lakei to lake i + 1 is denoted ti ( $0 < t_i \leŸ 192$). For example,t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4.


To help plan his fishing trip, John has gathered some information about the lakes. For each lakei, the number of fish expected to be caught in the initial 5 minutes, denotedfi ( $f_i \ge– 0$), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di ( $d_i \ge– 0$). If the number of fish expected to be caught in an interval is less than or equal to di, there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch.


Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

Input 

You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying f i ( $1 \leŸ i \leŸ n$), then a line of n integers d i ( $1 \leŸ i \leŸ n$), and finally, a line of n - 1 integers t i ( $1 \leŸ i Ÿ\le n - 1$). Input is terminated by a case in which n = 0.

Output 

For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected. If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.

Sample Input 

2
1
10 1
2 5
2
4
4
10 15 20 17
0 3 4 3
1 2 3
4
4
10 15 50 30
0 3 4 3
1 2 3
0

Sample Output 

45, 5
Number of fish expected: 31

240, 0, 0, 0
Number of fish expected: 480

115, 10, 50, 35
Number of fish expected: 724

贪心。蛋疼的题,4次PE,无语。。。。。。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct T
{
    int data,di,time;
} a[30];
int n,h,Data[30],D[30],T[30],t[30];
int search(int nn)
{
    int m=0,max=a[0].data;
    for(int i=1; i<=nn; i++)
        if(a[i].data>max)m=i,max=a[i].data;
    return m;
}
int maxsum(int nn)
{
    int s,hh=h*12-D[nn-1],sum=0;
    for(int i=0; i<=nn; i++)a[i].data=Data[i];
    memset(t,0,sizeof(t));
    while(hh>0)
    {
        s=search(nn);
        if(a[s].data>0)
        {
            sum+=a[s].data;
            a[s].data-=a[s].di;
            t[s]++;
        }
        else t[0]++;
        hh--;
    }
    return sum;
}
int compare()
{
    for(int i=0; i<n; i++)
        if(T[i]>t[i])return 1;
        else if(T[i]<t[i])return 0;
}
int MaxFish()
{
    int max=0,o,data=Data[0];
    memset(T,0,sizeof(T));
    o=T[0]=h*12;
    while(o--)
    {
        if(data>0)max+=data;
        else break;
        data-=a[0].di;
    }
    for(int i=1; i<n; i++)
    {
        int s=maxsum(i);
        if(s>max)for(int j=0; j<n; j++){T[j]=t[j];max=s;}
        else if(s==max&&!compare())for(int j=0; j<n; j++)T[j]=t[j];
    }
    return max;
}
int main()
{
   // freopen("1.txt","r",stdin);
   int id=0;
    while(cin>>n)
    {
        if(!n)return 0;
        else
        {
            if(id)cout<<endl;
            id++;
            cin>>h;
            int hh;
            for(int i=0; i<n; i++)cin>>Data[i];
            for(int i=0; i<n; i++)cin>>a[i].di;
            for(int i=0; i<n-1; i++)
            {
                cin>>hh;
                if(!i)D[i]=hh;
                else  D[i]=D[i-1]+hh;
            }
            int max=MaxFish();
            for(int i=0; i<n-1; i++)
                cout<<T[i]*5<<", ";
            cout<<T[n-1]*5<<endl;
            cout<<"Number of fish expected: "<<max<<endl;
        }
    }
    return 0;
}


Miguel A. Revilla

2000-02-09
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值